Q7

Problem with large workspace context capturing

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Cannot Reproduce
  • Affects Version/s: 1.0RC5
  • Fix Version/s: 1.2.20
  • Component/s: Runtime, UI
  • Labels:
    None

Description

When something fails on AUT side (like resource is out of sync with file system) during capturing, I see just EOFException: Connection not available

Activity

komaz added a comment - 27/Jul/11 6:51 PM

Exact stacktrace:

java.io.EOFException
at java.io.DataInputStream.readInt(DataInputStream.java:375)
at org.eclipse.ecl.internal.core.EMFStreamPipe.take(EMFStreamPipe.java:54)
at org.eclipse.ecl.internal.client.tcp.TcpSession$1.run(TcpSession.java:58)
at java.lang.Thread.run(Thread.java:680)

komaz added a comment - 28/Jul/11 2:18 PM

I think we just need correctly send error status into pipe and show error message on client side

Evgeny Tarasenko made changes - 28/Jul/11 5:48 PM
Field Original Value New Value
Assignee Alena Repina [ alena ] Evgeny Tarasenko [ etarasenko ]
Evgeny Tarasenko made changes - 28/Jul/11 5:49 PM
Status Open [ 1 ] In Progress [ 3 ]
Evgeny Tarasenko made changes - 29/Jul/11 11:13 AM
Summary Absolutely uninformative error messages when capturing workspace context fails Problem with large workspace context capturing
Ulyana Skorokhodova added a comment - 29/Jul/11 12:19 PM

Another steps to reproduce:

1) Import the attached workspace to VSD;
2) Create new workspace context and press "Capture" button;

Q7 will throw "Connection is not Available" error:

java.io.EOFException
at java.io.DataInputStream.readInt(Unknown Source)
at org.eclipse.ecl.internal.core.EMFStreamPipe.take(EMFStreamPipe.java:54)
at org.eclipse.ecl.internal.client.tcp.TcpSession$1.run(TcpSession.java:58)
at java.lang.Thread.run(Unknown Source)

Ulyana Skorokhodova made changes - 29/Jul/11 12:20 PM
Evgeny Tarasenko made changes - 29/Jul/11 2:26 PM
Status In Progress [ 3 ] Open [ 1 ]
Evgeny Tarasenko added a comment - 29/Jul/11 2:30 PM

Implemented changes:
Use new ECL TCP Server/Client.
Use binary serialization in EMFStreamPipe.
Show workaround solution when cannot capture context. (to increase -Xms -Xmx AUT VM arguments).

Evgeny Tarasenko made changes - 29/Jul/11 2:31 PM
Fix Version/s 1.0RC7 [ 10271 ]
Fix Version/s 1.0RC6 [ 10270 ]
Evgeny Tarasenko made changes - 11/Aug/11 3:00 PM
Fix Version/s 1.1M1 [ 10141 ]
Fix Version/s 1.0.1I1 [ 10271 ]
Priority Critical [ 2 ] Major [ 3 ]
Andrey Sobolev made changes - 10/Apr/12 11:44 AM
Fix Version/s 1.x [ 10141 ]
Fix Version/s 1.2.x [ 11172 ]
Assignee Evgeny Tarasenko [ etarasenko ] Ivan Inozemtsev [ komaz ]
Andrey Sobolev made changes - 16/Jan/13 5:54 PM
Fix Version/s 1.2.x [ 11172 ]
Fix Version/s 1.3.x [ 11471 ]
komaz added a comment - 01/Aug/13 7:33 PM

since we have linked resources, this problem is gone

Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open In Progress In Progress
23h 1 Evgeny Tarasenko 28/Jul/11 5:49 PM
In Progress In Progress Open Open
20h 37m 1 Evgeny Tarasenko 29/Jul/11 2:26 PM
Open Open Resolved Resolved
734d 5h 7m 1 komaz 01/Aug/13 7:33 PM

People

  • Assignee:
    komaz
    Reporter:
    komaz
Vote (0)
Watch (0)

Dates

  • Created:
    27/Jul/11 6:48 PM
    Updated:
    01/Aug/13 7:33 PM
    Resolved:
    01/Aug/13 7:33 PM