Q7

If "Single click" is set in Preferences, then editor cannot be opened from Explorer at the replaying of test

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.0.0
  • Fix Version/s: 1.3.x
  • Component/s: Runtime
  • Labels:
    None
  • Test Mode:
    Q7
  • Q7 test:
    EditorCanBeOpenedBySingleClick

Description

Steps to reproduce:
1. Set in "Preferences/General" the "Single click" check-box and save this change
2. Start the recording
3. Record the following actions:

  • Open Q7 Explorer
  • Click on the test case in Q7 Explorer - editor of test case is opened
  • Verify that editor is opened
    4. Replay this test
    Test is failed, opening of editor by one click is not reproduced.

Activity

komaz added a comment - 31/Aug/11 6:46 PM

we need to understand how to fix this issue correctly - looks like we do not fully understand circumstances of user actions during recording, therefore don't know which actions should be ignored and which are not in common case.

lena.platova added a comment - 13/Jun/12 6:29 PM - edited

Works manually, but test fails (see attachment)

Ulyana Skorokhodova added a comment - 16/Jun/15 6:50 PM

Test is fixed with get-item | click.


People

Vote (0)
Watch (0)

Dates

  • Created:
    31/Aug/11 1:10 PM
    Updated:
    16/Jun/15 6:50 PM
    Resolved:
    16/Jun/15 6:50 PM