Q7

Q7 cannot select link when it decorated with error icon

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Duplicate
  • Affects Version/s: 1.1
  • Fix Version/s: 1.1.5
  • Component/s: Runtime
  • Labels:

Description

Then there is another issue which got to do with validation errors as well. If there is a link provided with an error icon, that link isn't clicked later when the test is replayed. There is some ECL-Script generated when recording but the link with and without an error icon seems to differ. The link I'm talking about is red framed:

The script that is recorded when clicked:
get-view Properties | get-section "Script : org.example.MyScript" | get-link "<a>invoke(String, String, long)</a>"

click

This works only if there is no error icon. If there is an error icon, the same code is generated but is not clicked later.

Issue Links

Activity

Evgeny Tarasenko added a comment - 05/Dec/11 5:00 PM

Could not reproduce on test view with decorated link. Need customer AUT.

komaz added a comment - 21/Dec/11 5:35 PM

Most likely it is a duplicate for QS-1646. The issue is that Q7 incorrectly reproduced link clicks – instead of sending selection events with link text it sent sequence of mouse down and mouse up at 0:0 coordinates. Thus, in case there is a validation error, link is shifted few pixels left and mouse events not affect it


People

  • Assignee:
    komaz
    Reporter:
    komaz
Vote (0)
Watch (0)

Dates

  • Created:
    18/Nov/11 4:01 PM
    Updated:
    28/Dec/11 4:41 PM
    Resolved:
    21/Dec/11 5:36 PM