Q7

Cannot add element to the end of the list for "stringRefsToAttributes" property in table on test replay

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.1.2
  • Fix Version/s: 1.1.5
  • Component/s: Runtime
  • Labels:
    None

Description

Run 359863_AddSeveralReferences test
Test is failed with error
Execution failed on line 27 at column 9 (359863_AddSeveralReferences.test:27)
Caused by:
The Item "[]" could not be found.

In this step I tried to add element to the end of the list for "stringRefsToAttributes" property.

Activity

Ulyana Skorokhodova added a comment - 20/Dec/11 4:39 PM - edited

The reason is: Q7 doesn't record "expand" button click in Annotation Properties view.

Evgeny Tarasenko added a comment - 22/Dec/11 5:16 PM

Fixed, the reason that "select <ItemPath>" do not recording before "get-cell | click" command and if target item is child and parent not expanded
Q7 can't perform get-cell on right item.
Now "select <ItemPath>" always recorded before "get-cell | click" command and removed duplicated recording of "get-cell | click" commands.
Need to rerecord test or edit it by hands: for example instead
get-cell 4 0 | click
must be:
select "stringRefsToAttributes/EString" | get-cell 4 0 | click


People

Vote (0)
Watch (0)

Dates

  • Created:
    07/Dec/11 11:30 AM
    Updated:
    28/Dec/11 4:41 PM
    Resolved:
    22/Dec/11 5:27 PM