Q7

If file is defined as ignored file in Workspace context, then parent folder should be ignored too

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.1.2
  • Fix Version/s: 1.1.5
  • Component/s: Runtime
  • Labels:
    None

Description

eGit is used as AUT.
Steps to reproduce:
1. At the running test the following file is locked - TestGit\.git\objects\pack\pack*.pack.
And the following test cannot be run.
2. Set this file in the "Do not clear following folders or files" field of Workspace context
3. Apply Workspace context with clearing workspace.
Defined file is ignored, but applying context is failed, the following message is displayed:

Failed to apply context "WSContextWithFilledRep" caused by:
Failed to delete files or folders:
D:\Q7 application\aut-eGit\TestGit\.git\objects\pack
D:\Q7 application\aut-eGit\TestGit\.git\objects
D:\Q7 application\aut-eGit\TestGit\.git
D:\Q7 application\aut-eGit\TestGit

In this case all parent folders should be ignored too.

Activity

anastasia.ahramenko added a comment - 14/Dec/11 3:24 PM

Steps to reproduce:
1. Apply context with "project1/f1/f2/text.txt
2. Enter "project1/f1/*text.txt" in the ignore field
3. Apply workspace context
Error is displayed:
Failed to apply context "WS_ignore" caused by:
Failed to delete files or folders:
D:\Q7\project1\f1\f2


People

Vote (0)
Watch (0)

Dates

  • Created:
    12/Dec/11 12:54 PM
    Updated:
    28/Dec/11 4:41 PM
    Resolved:
    22/Dec/11 10:21 AM