Q7

Tests with control characters cannot be saved

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.1.3
  • Fix Version/s: 1.1.6
  • Component/s: Runtime
  • Labels:

Activity

komaz added a comment - 15/Feb/12 11:44 AM

As we have removed tesla content from tests starting from 1.1.6, this issue is fixed indirectly

komaz added a comment - 15/Dec/11 9:28 PM

Probably we should switch to binary serialization since Q7 1.2.0? I have no idea how to resolve this issue correctly.
I tried to set XML version to 1.1, it has solved issue with serialization, but caused issue with deserialization. Very strange. Fuck Form Feed character!!!

komaz added a comment - 15/Dec/11 9:01 PM

The problem is with 0xc character which cannot be serialized in XML 1.0. In ECL this character is correctly rendered as \f into string. However Tesla content creates huge problem when persistence manager saves it into XMI.
To reproduce:
1. Use Eclipse SDK as AUT
2. In AUT create java project which performs "System.out.println("aa\fbb")"
3. Start recording, assert text in console, try to save resulting script


People

  • Assignee:
    komaz
    Reporter:
    lena.platova
Vote (0)
Watch (0)

Dates

  • Created:
    15/Dec/11 5:13 PM
    Updated:
    07/Feb/13 11:26 AM
    Resolved:
    15/Feb/12 11:44 AM