Q7

get-item method infinity symbol

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 1.1
  • Fix Version/s: 1.1.5
  • Component/s: Core
  • Labels:
    None
  • ZendeskID:
    187

Description

Hi!

I%u2019d like to assert the following:

get-item "Form/<empty>
]-? , ?
[ Number Slider" -index 1 | get-property index | equals 19 | verify-true

This works for the first run. After closing and reopening the test case the %u221E is formatted into ?

get-item "Form/<empty>
]-? , ?
[ Number Slider" -index 1 | get-property index | equals 19 | verify-true

So i replaced the question mark with the following: \u221E

This works quite good for other cases!

select "Form/<empty> \\]-\u221E , \u221E
[ Number Slider" | get-menu "New Sibling/Image" | click

But in this case%u2026

get-item "Form/<empty> \\]-\u221E, \u221E
[ Number Slider" -index 1 | get-property index | equals 19 | verify-true

%u2026I get the following error:

Execution failed on line 43 at column 79 (SIXPLUS-217-Number_Slider_SIBLING.test:43)

Caused by:

The Item "[Form, <empty> ]-\u221E, \u221E[ Number Slider%1%]" could not be found.

Also after removing the index parameter it was not successful

get-item "Form/<empty> \\]-\u221E, \u221E
[ Number Slider" | get-property index | equals 18 | verify-true

Both items exist which is proven when running the test with the %u221E symbol.

But why does the \u221E code sometimes work and sometimes not?

Thank you!

Activity

komaz added a comment - 10/Jan/12 9:01 PM

AS,
Please take a look at this issue tomorrow morning. To reproduce:
1. Create empty test case
2. Type 'alert "∞∞∞"' into Script
3. Save, close, open
4. See that infinity characters are replaced with question marks.

The issue is in our persistence layer - looks like during serialization platform-dependent encoding is used somewhere. I couldn't reproduce this issue on Mac OS X until I've launched Q7 with -Dfile.encoding=windows-1251 VM argument

komaz added a comment - 10/Jan/12 9:56 PM

Never mind, I've pushed a fix, please review changes

Andrey Sobolev added a comment - 11/Jan/12 8:42 AM

Looks fine.

Andrey Sobolev added a comment - 11/Jan/12 8:42 AM

Fixed.


People

  • Assignee:
    komaz
    Reporter:
    zendesk
Vote (0)
Watch (0)

Dates

  • Created:
    10/Jan/12 1:51 AM
    Updated:
    11/Jan/12 8:42 AM
    Resolved:
    11/Jan/12 8:42 AM