Q7

64-bt Q7 runner does not handle 32-bit AUTS

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.1.6
  • Fix Version/s: 1.1.7
  • Component/s: Runner
  • Labels:

Description

Besides non-working, it also fails to properly report a problem:

AUT-0:Launching
AUT-0:Product: com.adobe.flexbuilder.standalone.producte36
AUT-0:Application: com.adobe.flexbuilder.standalone.FlashBuilderApplication
/Users/testertester/q7-runner/aut-ws-0: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog -data /Users/testertester/q7-runner/aut-ws-0
/Users/testertester/q7-runner/aut-ws-0: AUT VM arguments: -Xms256m -Xmx512m -XX:MaxPermSize=256m -XX:PermSize=64m "-Xdock:name=Flash Builder" -Xdock:icon=../Resources/fb_app.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Declipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication -Declipse.product=com.adobe.flexbuilder.standalone.producte36 -Dfile.encoding=UTF-8
AUT-0:Failed to launch cause:null

Activity

Hide
Andrey Sobolev added a comment - 08/Feb/12 2:03 PM

Fixed.

Show
Andrey Sobolev added a comment - 08/Feb/12 2:03 PM Fixed.
Hide
komaz added a comment - 08/Feb/12 6:29 PM

Initializing target platform...
***WARNING: Display must be created on main thread due to Cocoa restrictions.
Validating target platform...
Target platform is valid.
Looking for tests...
Testcase Artifacts:260
AUT-0:Launching
AUT-0:Product: com.adobe.flexbuilder.standalone.producte36
AUT-0:Application: com.adobe.flexbuilder.standalone.FlashBuilderApplication
AUT-0:Architecture: x86
/Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog -data /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0
/Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT VM arguments: -Xms256m -Xmx512m -XX:MaxPermSize=256m -XX:PermSize=64m "-Xdock:name=Flash Builder" -Xdock:icon=../Resources/fb_app.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Declipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication -Declipse.product=com.adobe.flexbuilder.standalone.producte36 -Dfile.encoding=UTF-8
AUT-0:Failed to launch cause:null
Failed to launch AUT:AUT could not be invoked because:null
AUT-0:Launching
AUT-0:Product: com.adobe.flexbuilder.standalone.producte36
AUT-0:Application: com.adobe.flexbuilder.standalone.FlashBuilderApplication
AUT-0:Architecture: x86
/Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog -data /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0
/Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT VM arguments: -Xms256m -Xmx512m -XX:MaxPermSize=256m -XX:PermSize=64m "-Xdock:name=Flash Builder" -Xdock:icon=../Resources/fb_app.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Declipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication -Declipse.product=com.adobe.flexbuilder.standalone.producte36 -Dfile.encoding=UTF-8
AUT-0:Failed to launch cause:null
Failed to launch AUT:AUT could not be invoked because:null
AUT-0:Launching
AUT-0:Product: com.adobe.flexbuilder.standalone.producte36
AUT-0:Application: com.adobe.flexbuilder.standalone.FlashBuilderApplication
AUT-0:Architecture: x86
/Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog -data /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0
/Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT VM arguments: -Xms256m -Xmx512m -XX:MaxPermSize=256m -XX:PermSize=64m "-Xdock:name=Flash Builder" -Xdock:icon=../Resources/fb_app.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Declipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication -Declipse.product=com.adobe.flexbuilder.standalone.producte36 -Dfile.encoding=UTF-8
AUT-0:Failed to launch cause:null
Failed to launch AUT:AUT could not be invoked because:null
AUT-0:Launching
AUT-0:Product: com.adobe.flexbuilder.standalone.producte36
AUT-0:Application: com.adobe.flexbuilder.standalone.FlashBuilderApplication
AUT-0:Architecture: x86
/Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog -data /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0
/Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT VM arguments: -Xms256m -Xmx512m -XX:MaxPermSize=256m -XX:PermSize=64m "-Xdock:name=Flash Builder" -Xdock:icon=../Resources/fb_app.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Declipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication -Declipse.product=com.adobe.flexbuilder.standalone.producte36 -Dfile.encoding=UTF-8
AUT-0:Failed to launch cause:null

Show
komaz added a comment - 08/Feb/12 6:29 PM Initializing target platform... ***WARNING: Display must be created on main thread due to Cocoa restrictions. Validating target platform... Target platform is valid. Looking for tests... Testcase Artifacts:260 AUT-0:Launching AUT-0:Product: com.adobe.flexbuilder.standalone.producte36 AUT-0:Application: com.adobe.flexbuilder.standalone.FlashBuilderApplication AUT-0:Architecture: x86 /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog -data /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0 /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT VM arguments: -Xms256m -Xmx512m -XX:MaxPermSize=256m -XX:PermSize=64m "-Xdock:name=Flash Builder" -Xdock:icon=../Resources/fb_app.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Declipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication -Declipse.product=com.adobe.flexbuilder.standalone.producte36 -Dfile.encoding=UTF-8 AUT-0:Failed to launch cause:null Failed to launch AUT:AUT could not be invoked because:null AUT-0:Launching AUT-0:Product: com.adobe.flexbuilder.standalone.producte36 AUT-0:Application: com.adobe.flexbuilder.standalone.FlashBuilderApplication AUT-0:Architecture: x86 /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog -data /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0 /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT VM arguments: -Xms256m -Xmx512m -XX:MaxPermSize=256m -XX:PermSize=64m "-Xdock:name=Flash Builder" -Xdock:icon=../Resources/fb_app.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Declipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication -Declipse.product=com.adobe.flexbuilder.standalone.producte36 -Dfile.encoding=UTF-8 AUT-0:Failed to launch cause:null Failed to launch AUT:AUT could not be invoked because:null AUT-0:Launching AUT-0:Product: com.adobe.flexbuilder.standalone.producte36 AUT-0:Application: com.adobe.flexbuilder.standalone.FlashBuilderApplication AUT-0:Architecture: x86 /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog -data /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0 /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT VM arguments: -Xms256m -Xmx512m -XX:MaxPermSize=256m -XX:PermSize=64m "-Xdock:name=Flash Builder" -Xdock:icon=../Resources/fb_app.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Declipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication -Declipse.product=com.adobe.flexbuilder.standalone.producte36 -Dfile.encoding=UTF-8 AUT-0:Failed to launch cause:null Failed to launch AUT:AUT could not be invoked because:null AUT-0:Launching AUT-0:Product: com.adobe.flexbuilder.standalone.producte36 AUT-0:Application: com.adobe.flexbuilder.standalone.FlashBuilderApplication AUT-0:Architecture: x86 /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog -data /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0 /Users/ivaninozemtsev/work/f4/src/f4.git/f4tests/target/aut-ws-0: AUT VM arguments: -Xms256m -Xmx512m -XX:MaxPermSize=256m -XX:PermSize=64m "-Xdock:name=Flash Builder" -Xdock:icon=../Resources/fb_app.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -Declipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication -Declipse.product=com.adobe.flexbuilder.standalone.producte36 -Dfile.encoding=UTF-8 AUT-0:Failed to launch cause:null
Hide
Andrey Sobolev added a comment - 08/Feb/12 9:32 PM

Very strange, will check tomorrow.

Show
Andrey Sobolev added a comment - 08/Feb/12 9:32 PM Very strange, will check tomorrow.
Hide
Andrey Sobolev added a comment - 09/Feb/12 4:17 PM

Fixed.

Show
Andrey Sobolev added a comment - 09/Feb/12 4:17 PM Fixed.

People

Vote (0)
Watch (0)

Dates

  • Created:
    07/Feb/12 9:44 PM
    Updated:
    09/Feb/12 4:17 PM
    Resolved:
    09/Feb/12 4:17 PM