Q7

Incorrect message when execute test case with unreferenced context

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.0
  • Fix Version/s: 1.2.1
  • Component/s: Launching (Runtime)
  • Labels:
    None
  • Test Mode:
    Manual

Description

Steps to reproduce

1. Use workspace attached
2. Add Context2 from p2 into scenario1 from p1, save
3. Delete p2

There is no "References found" in Delete window. If scenario's editor is opened, context remains in it, if editor was closed, context becomes unresolved. Message when running scenario:

Execution failed
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at org.eclipse.emf.ecore.impl.EFactoryImpl.createFromString(EFactoryImpl.java:415)
at org.eclipse.ecl.core.impl.CoreFactoryImpl.createThrowableFromString(CoreFactoryImpl.java:341)
at org.eclipse.ecl.core.impl.CoreFactoryImpl.createFromString(CoreFactoryImpl.java:104)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl$EObjectInputStream.loadFeatureValue(BinaryResourceImpl.java:1769)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl$EObjectInputStream.loadEObject(BinaryResourceImpl.java:1710)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl$EObjectInputStream.loadFeatureValue(BinaryResourceImpl.java:1733)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl$EObjectInputStream.loadEObject(BinaryResourceImpl.java:1710)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl$EObjectInputStream.loadResource(BinaryResourceImpl.java:1437)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl.doLoad(BinaryResourceImpl.java:195)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1511)
at org.eclipse.ecl.internal.core.EMFStreamPipe.take(EMFStreamPipe.java:109)
at org.eclipse.ecl.client.tcp.EclTcpSession.writeOutput(EclTcpSession.java:189)
at org.eclipse.ecl.client.tcp.EclTcpSession.access$6(EclTcpSession.java:186)
at org.eclipse.ecl.client.tcp.EclTcpSession$1.run(EclTcpSession.java:97)
at java.lang.Thread.run(Unknown Source)

Activity

Andrey Sobolev added a comment - 23/Apr/12 3:15 PM

We need to think about this a little bit more.
Since then you delete project, you could not remove it from workspace without real file delete.
Also for project delete it could be very long to scan all references.

Andrey Sobolev added a comment - 23/Apr/12 5:25 PM

Fixed.


People

Vote (0)
Watch (0)

Dates

  • Created:
    23/Apr/12 2:42 PM
    Updated:
    23/Apr/12 6:15 PM
    Resolved:
    23/Apr/12 5:25 PM