Q7

Unable to replay java class outline assertion when outline is opened using hotkey

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Cannot Reproduce
  • Affects Version/s: 1.2.1
  • Fix Version/s: 1.2.11
  • Component/s: Launching (Runtime)
  • Labels:
  • Environment:
    Eclipse Modeling Tools, works ok on Eclipse 3.7.2
  • Test Mode:
    Manual

Description

Works ok when outline is opened from menu

Activity

Andrey Sobolev added a comment - 30/Jul/12 10:46 AM

Problem related to recording:
Then I just try to record Cmd+O in java editor, I've got following ecl script:

with [get-editor "test.java" | get-text-viewer] { set-caret-pos 9 1 key-type "M1+o" hover-text 9 1 -with M1 }
get-window -from "Window.createShell()" | get-editbox | key-type "M1+o"
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

The last sentence are should not be recorded.

Andrey Sobolev added a comment - 30/Jul/12 11:17 AM

Problem is because KeyDown is processed agains text editor, but KeyUp is processed against popup window.

Andrey Sobolev added a comment - 30/Jul/12 11:40 AM

Fixed.

lena.platova added a comment - 05/Oct/12 3:58 PM

Now Ctrl+Alt+Q O is recorded as

get-view "Task List" | get-tree | type-text o

Andrey Sobolev added a comment - 30/Nov/12 2:42 PM

Cannot reproduce, checked on OSX and Windows.


People

Vote (0)
Watch (0)

Dates

  • Created:
    30/May/12 12:51 PM
    Updated:
    30/Nov/12 2:42 PM
    Resolved:
    30/Nov/12 2:42 PM