Q7

Unclear error message when files are locked

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.2
  • Fix Version/s: 1.2.6
  • Component/s: Runtime
  • Labels:
  • Test Mode:
    Manual

Description

Use iTest as an AUT.
Import the attached test case.
Run it ~10 times.

1. Sometimes the test fails (failed to delete some resources);
2. In case it has failed - "Add to Test Case Wizard" window is not closed by workbench context.

Activity

sergey added a comment - 07/Aug/12 5:37 PM

Can not reproduce, have run the test for more than 30 times.

Andrey Sobolev added a comment - 07/Aug/12 7:51 PM

Problem could be because of issue with iTest then some file is not closed. We could try adding force calling of java Garbage collection, if such situation are happen.
Also Better idea will be to aspect java input streams, and monitor them during execution, this way will include a lot more work.

komaz added a comment - 09/Aug/12 10:32 PM

If the problem happens because of AUT's problem, we probably should not make any workarounds like closing streams instead of AUT, but report error more thoroughly – like, report that some files are still in use (and probably use aspects to monitor who opens a file).

komaz added a comment - 15/Aug/12 8:06 PM

Looks like we seen similar problem with tigerstripe dogfood

komaz added a comment - 10/Sep/12 2:12 PM

Let us improve error reporting so that it does not look like Q7 bug

komaz added a comment - 10/Sep/12 2:13 PM

And let's fail fast in case of deletion problem

Andrey Sobolev added a comment - 12/Sep/12 5:25 PM

Fixed.


People

Vote (0)
Watch (0)

Dates

  • Created:
    10/Jul/12 1:41 PM
    Updated:
    14/Sep/12 6:38 PM
    Resolved:
    12/Sep/12 5:25 PM