Q7

Q7 Eclipse Application as AUT launch configuration incorrectly process workspace plugins, then no plugins selection was performed.

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.3
  • Fix Version/s: 1.2.3
  • Component/s: Launching (Runtime)
  • Labels:
    None
  • Test Mode:
    Manual

Description

Then Eclipse launch configuration used as target for Q7 Eclipse Application as AUT, and for source configuration plugins, or features mode are not selected.
So list of plugins are not stored in source launch configuration, in this case Q7 Eclipse Application as AUT works incorrectly,
plugins from workspace are included in different order, or could be not included in launch.

Activity

Andrey Sobolev added a comment - 28/Jul/12 2:28 PM

Launching are fixed, and commited.

but in my environment I've see exceptions like:

After changes to new launching model and resolving startup issues,
I've see following exception in console:

Caused by: java.lang.NullPointerException
at org.aspectj.weaver.bcel.LazyMethodGen.<init>(LazyMethodGen.java:205)
at org.aspectj.weaver.bcel.LazyClassGen.<init>(LazyClassGen.java:307)
at org.aspectj.weaver.bcel.BcelObjectType.getLazyClassGen(BcelObjectType.java:558)
at org.aspectj.weaver.bcel.BcelWeaver.weave(BcelWeaver.java:1685)
at org.aspectj.weaver.bcel.BcelWeaver.weaveWithoutDump(BcelWeaver.java:1636)
at org.aspectj.weaver.bcel.BcelWeaver.weaveAndNotify(BcelWeaver.java:1401)
at org.aspectj.weaver.bcel.BcelWeaver.weave(BcelWeaver.java:1187)
at org.aspectj.weaver.tools.WeavingAdaptor.getWovenBytes(WeavingAdaptor.java:525)
at org.aspectj.weaver.tools.WeavingAdaptor.weaveClass(WeavingAdaptor.java:361)
at org.eclipse.equinox.weaving.aspectj.loadtime.OSGiWeavingAdaptor.weaveClass(OSGiWeavingAdaptor.java:121)
at org.eclipse.equinox.weaving.aspectj.AspectJWeavingService.preProcess(AspectJWeavingService.java:151)
at org.eclipse.equinox.weaving.adaptors.WeavingAdaptor.weaveClass(WeavingAdaptor.java:245)
at org.eclipse.equinox.weaving.hooks.WeavingHook.processClass(WeavingHook.java:126)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:594)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:562)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:486)
at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:459)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:400)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:476)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:429)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:417)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
at org.eclipse.jdt.internal.ui.wizards.buildpaths.newsourcepage.DialogPackageExplorer.setSelection(DialogPackageExplorer.java:461)
at org.eclipse.jdt.internal.ui.wizards.buildpaths.newsourcepage.DialogPackageExplorer.setInput(DialogPackageExplorer.java:438)
at org.eclipse.jdt.internal.ui.wizards.buildpaths.newsourcepage.NewSourceContainerWorkbookPage.doUpdateUI(NewSourceContainerWorkbookPage.java:138)
at org.eclipse.jdt.internal.ui.wizards.buildpaths.newsourcepage.NewSourceContainerWorkbookPage.access$0(NewSourceContainerWorkbookPage.java:137)
at org.eclipse.jdt.internal.ui.wizards.buildpaths.newsourcepage.NewSourceContainerWorkbookPage$1.run(NewSourceContainerWorkbookPage.java:131)
at org.eclipse.swt.widgets.RunnableLock.run_aroundBody0(RunnableLock.java:35)
at org.eclipse.swt.widgets.RunnableLock$AjcClosure1.run(RunnableLock.java:1)
at com.xored.tesla.swt.aspects.DisplayAspect.ajc$around$com_xored_tesla_swt_aspects_DisplayAspect$10$90b1ba39proceed(DisplayAspect.aj:292)
at com.xored.tesla.swt.aspects.DisplayAspect.ajc$around$com_xored_tesla_swt_aspects_DisplayAspect$10$90b1ba39(DisplayAspect.aj:316)
at org.eclipse.swt.widgets.RunnableLock.run_aroundBody2(RunnableLock.java:35)
at org.eclipse.swt.widgets.RunnableLock$AjcClosure3.run(RunnableLock.java:1)
at com.xored.sherlock.aspects.swt.DisplayAspect.ajc$around$com_xored_sherlock_aspects_swt_DisplayAspect$2$90b1ba39proceed(DisplayAspect.aj:38)
at com.xored.sherlock.aspects.swt.DisplayAspect.ajc$around$com_xored_sherlock_aspects_swt_DisplayAspect$2$90b1ba39(DisplayAspect.aj:60)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
... 111 more

So continuing work.

Andrey Sobolev added a comment - 30/Jul/12 10:00 AM

Fixed, by using aspectj 1.7, and ajdt 2.2 QS-1943


People

Vote (0)
Watch (0)

Dates

  • Created:
    27/Jul/12 12:17 PM
    Updated:
    30/Jul/12 10:00 AM
    Resolved:
    30/Jul/12 10:00 AM