Q7

Failed to select value from combo in cell

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.2
  • Fix Version/s: 1.2.4
  • Component/s: None
  • Labels:
  • Test Mode:
    Q7
  • Q7 test:
    SelectValueFromComboInCell

Description

Hi,

I've got a combo-selection issue with Q7. There is a Datatype Editor in our Solvatio, which enables you to create a custom datatype with some fields of any simpletype. The screenshot shows the moment when a field is selected and can be edited. The datatype of the field can be edited with a combo-box.

[cid:image001.jpg@01CD667C.6706A900]

The code Q7 generated in case of selecting and editing the datatype is the following.

with [get-editor "SIXPLUS_207_datatype.sdt" | get-tree] { select "SIXPLUS_207_datatype/string_field : String" | activate-cell-edit get-combo | set-text Object apply-cell-edit }

When the code is executed it seems, that the combo-box isn't selected but Q7 "tries" to write the text ("long") in the first field/column and in this case this would be an invalid identifier and is therefore rejected. The result is, that the datatype hasn't changed.

I tried some other commands manually, but was not successful. Do you have a guess how to edit that combo-box?

Thanks a lot!

Greetings

Johannes

Activity

komaz added a comment - 30/Jul/12 3:46 PM

Probably the problem is with composite cell editor. Andrey, please consider this issue with higher priority than control decorators

Andrey Sobolev added a comment - 31/Jul/12 6:34 PM

Checked composite CellEditor, works fine, at least for OSX. Need to check for windows.

Andrey Sobolev added a comment - 31/Jul/12 6:36 PM

Project with sample tree, cell editor composite.

Andrey Sobolev added a comment - 02/Aug/12 3:08 PM

Problem was related to following Q7 operation:

Then get-combo | set-text Value is executed, and combo is located in CellEditor composite,
Q7 was send FocusIn, and do force of focus object change.

But in case then focus lost listener is registered for text control, so focusIn calling apply previous value, so it looks like no actions are performed.

I've disabling sending Focus events for both Combo and CCombo in case they are in CellEdit.

Andrey Sobolev added a comment - 02/Aug/12 3:08 PM

Fixed.

komaz added a comment - 06/Aug/12 9:32 PM

issue still there, need to find a way to share email with more info

Andrey Sobolev added a comment - 09/Aug/12 3:32 PM

Sample updated to work with 2 controls in composite: edit box and combo box.

On recording snippet is following:
with [get-view "Q7 Testing" | get-section "CellEdit Tree Test" | get-tree] { select root1 | activate-cell-edit -column 1 get-editbox | set-focus select root1 | get-editbox | set-text 123 get-combo | set-text 456 apply-cell-edit }

Replayed successfully on OSX and Windows.

Andrey Sobolev added a comment - 09/Aug/12 3:46 PM

Root of issue could be in cell editor implementation:

apply-cell-editor command do following actions:

1) call method cellEditor.valueChanged();
2) call method cellEditor.fireApplyEditorValue();
3) if (cellEditor instanceof ComboBoxViewerCellEditor) { call method cellEditor.applyEditorValueAndDeactivate(); }
3) cellEditor.deactivate();

So one of reasons cell editor editing is not replayed could be different apply strategy.

Andrey Sobolev added a comment - 09/Aug/12 3:46 PM

Resolving as Fixed.


People

  • Assignee:
    komaz
    Reporter:
    komaz
Vote (0)
Watch (0)

Dates

  • Created:
    27/Jul/12 5:59 PM
    Updated:
    10/Aug/12 2:01 PM
    Resolved:
    09/Aug/12 3:46 PM