Q7

hover-text is recorded then information control are shown using keyboard.

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Won't Fix
  • Affects Version/s: 1.2.2, 1.2.17
  • Fix Version/s: 1.2.19
  • Component/s: Recording, Runtime
  • Labels:
    None
  • Test Mode:
    Manual

Description

Following scenario is recorded if press Cmd + O in java editor.

with [get-editor "test.java" | get-text-viewer] { 
    set-caret-pos 9 1 
    key-type "M1+o" 
    hover-text 9 1 -with M1 
} 

hover-text seem not be required, sometimes, because of hover-text information control is hided.

Activity

Andrey Sobolev made changes - 30/Jul/12 11:50 AM
Field Original Value New Value
Summary hove-text is recorded then information control are shown using keyboard. hover-text is recorded then information control are shown using keyboard.
Andrey Sobolev added a comment - 30/Jul/12 11:50 AM

Fixed.

Andrey Sobolev made changes - 30/Jul/12 11:50 AM
Resolution Fixed [ 1 ]
Status Open [ 1 ] Resolved [ 5 ]
Ulyana Skorokhodova added a comment - 05/Mar/13 1:36 PM

Problem still exists.

Import the attached test case.
Use Eclipse as AUT.
Try to re-capture the test case:

1. Click into Class1 editor (somewhere at 2nd line);
2. Press Ctrl+O;
3. Type "main" and press RETURN key.

The following code is recorded:

with [get-editor "Class1.java" | get-text-viewer] {
    hover-text 2 17
    set-caret-pos 2 14
    key-type "M1+o"
    hover-text 2 17 -with M1
}
with [get-window -from "Window.createShell()" | get-editbox] {
    set-text main
    key-type Enter
}
get-editor "Class1.java" | get-text-viewer | key-type Enter

4. Try to replay.

Test fails to locate assistant window because of the hover-text command:

Execution failed on line 7 at column 7 (JavaProjectWithClass.test:7)
Caused by:
The Window "[parentClass, Window.createShell()]" could not be found.

5. Comment line with

hover-text 2 17 -with M1

6. Try to replay. Test goes further but performs wrong action because key-type Enter command was recorded twice (in Class editor as well as in Assistant window) although it was pressed in assistant window only.

If you comment last line

get-editor "Class1.java" | get-text-viewer | key-type Enter

test will be replayed correctly.

with [get-editor "Class1.java" | get-text-viewer] {
    hover-text 2 17
    set-caret-pos 2 14
    key-type "M1+o"
    hover-text 2 17 -with M1
}
with [get-window -from "Window.createShell()" | get-editbox] {
    set-text main
    key-type Enter
}
get-editor "Class1.java" | get-text-viewer | key-type Enter
4. Try to replay. Test fails to locate assistant window because of the hover-text command: Execution failed on line 7 at column 7 (JavaProjectWithClass.test:7) Caused by: The Window "[parentClass, Window.createShell()]" could not be found. 5. Comment line with
hover-text 2 17 -with M1
6. Try to replay. Test goes further but performs wrong action because key-type Enter command was recorded twice (in Class editor as well as in Assistant window) although it was pressed in assistant window only. If you comment last line
get-editor "Class1.java" | get-text-viewer | key-type Enter
test will be replayed correctly.
Ulyana Skorokhodova made changes - 05/Mar/13 1:36 PM
Status Resolved [ 5 ] Reopened [ 4 ]
Resolution Fixed [ 1 ]
Ulyana Skorokhodova made changes - 05/Mar/13 1:37 PM
Attachment JavaProjectWithClass.test [ 13291 ]
Ulyana Skorokhodova made changes - 05/Mar/13 1:38 PM
Component/s Recording [ 11130 ]
Affects Version/s 1.2.17 [ 11976 ]
komaz added a comment - 09/Apr/13 12:54 PM - edited

Tried on Mac and Windows. Issue is reproducible only when I do the following:

  1. pressing M1+o
  2. releasing o
  3. move the mouse over the source code wihout releasing M1

In the scenario above I guess the behavior is correct. Possible further improvements might be to either don't record hover-text when it is not really needed or to make somehow that this quick outline window is not closed during replay of hover-text.

  1. pressing M1+o
  2. releasing o
  3. move the mouse over the source code wihout releasing M1
In the scenario above I guess the behavior is correct. Possible further improvements might be to either don't record hover-text when it is not really needed or to make somehow that this quick outline window is not closed during replay of hover-text.
Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open Resolved Resolved
10m 51s 1 Andrey Sobolev 30/Jul/12 11:50 AM
Resolved Resolved Reopened Reopened
218d 2h 46m 1 Ulyana Skorokhodova 05/Mar/13 1:36 PM
Reopened Reopened In Progress In Progress
34d 20h 6m 1 komaz 09/Apr/13 10:43 AM
In Progress In Progress Resolved Resolved
2h 11m 1 komaz 09/Apr/13 12:54 PM