Q7

Failed to get property nodes for path "" error.

Details

  • Test Mode:
    Manual

Description

Got the following exception each time I run TopologyEditor tests:

org.eclipse.core.runtime.CoreException: Failed to get property nodes for path "".
at com.xored.q7.internal.launching.aut.BaseAutLaunch.execute(BaseAutLaunch.java:117)
at com.xored.q7.ui.panels.assertion.AssertContentProvider.loadChildren(AssertContentProvider.java:88)
at com.xored.q7.ui.panels.assertion.AssertionPanelWindow.createAssertTree(AssertionPanelWindow.java:656)
at com.xored.q7.ui.panels.assertion.AssertionPanelWindow.setInput(AssertionPanelWindow.java:812)
at com.xored.q7.ui.panels.main.ControlPanelWindow$AssertAddedListener$1.run(ControlPanelWindow.java:1022)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2701)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2665)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2499)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:679)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:668)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Caused by: java.lang.Throwable: java.lang.NullPointerException
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
at java.lang.reflect.Constructor.newInstance(Unknown Source)
at org.eclipse.emf.ecore.impl.EFactoryImpl.createFromString(EFactoryImpl.java:415)
at org.eclipse.ecl.core.impl.CoreFactoryImpl.createThrowableFromString(CoreFactoryImpl.java:385)
at org.eclipse.ecl.core.impl.CoreFactoryImpl.createFromString(CoreFactoryImpl.java:108)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl$EObjectInputStream.loadFeatureValue(BinaryResourceImpl.java:1769)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl$EObjectInputStream.loadEObject(BinaryResourceImpl.java:1710)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl$EObjectInputStream.loadFeatureValue(BinaryResourceImpl.java:1733)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl$EObjectInputStream.loadEObject(BinaryResourceImpl.java:1710)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl$EObjectInputStream.loadResource(BinaryResourceImpl.java:1437)
at org.eclipse.emf.ecore.resource.impl.BinaryResourceImpl.doLoad(BinaryResourceImpl.java:195)
at org.eclipse.emf.ecore.resource.impl.ResourceImpl.load(ResourceImpl.java:1511)
at org.eclipse.ecl.internal.core.EMFStreamPipe.take(EMFStreamPipe.java:109)
at org.eclipse.ecl.client.tcp.EclTcpSession.writeOutput(EclTcpSession.java:189)
at org.eclipse.ecl.client.tcp.EclTcpSession.access$6(EclTcpSession.java:186)
at org.eclipse.ecl.client.tcp.EclTcpSession$1.run(EclTcpSession.java:97)
at java.lang.Thread.run(Unknown Source)

Activity

Ulyana Skorokhodova made changes - 15/Aug/12 4:08 PM
Field Original Value New Value
Priority Major [ 3 ] Minor [ 4 ]
komaz added a comment - 15/Aug/12 4:35 PM

Can it be related to changes to emf resources?

Andrey Sobolev added a comment - 15/Aug/12 6:01 PM

Может, такую же штуку я ловил когда пытался рекордить с Q7 в AUT в котором EMF 2.8

komaz added a comment - 15/Aug/12 7:53 PM

we cannot ship 1.2.5 without investigating this issue

Andrey Sobolev made changes - 16/Aug/12 12:15 PM
Status Open [ 1 ] In Progress [ 3 ]
Andrey Sobolev added a comment - 16/Aug/12 1:49 PM

Issue could not be relevant to 1.2.5 since, stack trace is only for 1.2.4.

Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open In Progress In Progress
20h 7m 1 Andrey Sobolev 16/Aug/12 12:15 PM
In Progress In Progress Resolved Resolved
4h 12m 1 komaz 16/Aug/12 4:28 PM

Dates

  • Created:
    15/Aug/12 4:08 PM
    Updated:
    16/Aug/12 4:28 PM
    Resolved:
    16/Aug/12 4:28 PM