Q7

AUT from sources does not work when eclipse folder is write-protected

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Minor Minor
  • Resolution: Cannot Reproduce
  • Affects Version/s: 1.2.7
  • Fix Version/s: 1.2.8
  • Component/s: Launching (Runtime)
  • Labels:
    None
  • Test Mode:
    Manual

Description

  1. Unpack eclipse to write-protected location.
  2. Install Q7 Feature. The plugins will be put into ~/.eclipse/org.eclipse.platform_3.xxx/plugins
  3. AUT from sources launching fails with: No org.eclipse.equinox.weaving.hook plugin
    See whether we can workaround this. If no, just update instructions on AUT from source usage

Activity

Andrey Sobolev added a comment - 14/Oct/12 2:24 PM

Checked for OSX and Windows, can't reproduce issue.

Added one probable fix for this issue, by filtering out aspectj and weaving hook from install location then launch with "Eclipse Application with Q7".


People

Vote (0)
Watch (0)

Dates

  • Created:
    12/Oct/12 4:50 PM
    Updated:
    14/Oct/12 2:56 PM
    Resolved:
    14/Oct/12 2:56 PM