Q7

Unable to create new AUT

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.8
  • Fix Version/s: 1.2.9
  • Component/s: Launching (Runtime)
  • Labels:
    None
  • Environment:
    winxpplatova, q7 1.2.8, Vozone 7.0.0
  • Test Mode:
    Manual

Description

java.lang.NullPointerException
at com.xored.q7.launching.internal.target.TargetPlatformHelper.isValidId(TargetPlatformHelper.java:608)
at com.xored.q7.launching.internal.target.TargetPlatformHelper.getDefaultProduct(TargetPlatformHelper.java:614)
at com.xored.q7.launching.ext.Q7LaunchingUtil.updateLaunchConfiguration(Q7LaunchingUtil.java:95)
at com.xored.q7.launching.ext.Q7LaunchingUtil.createLaunchConfiguration(Q7LaunchingUtil.java:85)
at com.xored.q7.internal.launching.ext.ui.wizards.NewAUTWizard.performFinish(NewAUTWizard.java:50)
at org.eclipse.jface.wizard.WizardDialog.finishPressed(WizardDialog.java:827)
at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:432)
at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:624)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:240)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4165)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3754)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:825)
at org.eclipse.jface.window.Window.open(Window.java:801)
at com.xored.q7.ui.launching.aut.BasicAUTComposite.addAut(BasicAUTComposite.java:249)
at com.xored.q7.ui.launching.aut.AUTViewComposite$4.run(AUTViewComposite.java:68)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
at org.eclipse.jface.action.ActionContributionItem$6.handleEvent(ActionContributionItem.java:452)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4165)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3754)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)

org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
at org.eclipse.swt.SWT.error(SWT.java:4282)
at org.eclipse.swt.SWT.error(SWT.java:4197)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:138)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.block(ModalContext.java:173)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:388)
at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:507)
at com.xored.q7.internal.launching.ext.ui.TimeTriggeredProgressMonitorDialog.access$6(TimeTriggeredProgressMonitorDialog.java:1)
at com.xored.q7.internal.launching.ext.ui.TimeTriggeredProgressMonitorDialog$2.run(TimeTriggeredProgressMonitorDialog.java:198)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at com.xored.q7.internal.launching.ext.ui.TimeTriggeredProgressMonitorDialog.run(TimeTriggeredProgressMonitorDialog.java:212)
at com.xored.q7.internal.launching.ext.ui.wizards.NewAUTPage$2.runInUIThread(NewAUTPage.java:277)
at org.eclipse.ui.progress.UIJob$1.run(UIJob.java:95)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4140)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3757)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:825)
at org.eclipse.jface.window.Window.open(Window.java:801)
at com.xored.q7.ui.launching.aut.BasicAUTComposite.addAut(BasicAUTComposite.java:249)
at com.xored.q7.ui.launching.aut.AUTViewComposite$4.run(AUTViewComposite.java:68)
at org.eclipse.jface.action.Action.runWithEvent(Action.java:498)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)
at org.eclipse.jface.action.ActionContributionItem$6.handleEvent(ActionContributionItem.java:452)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1053)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4165)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3754)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
Caused by: java.lang.NullPointerException
at com.xored.q7.launching.internal.target.TargetPlatformHelper.isValidId(TargetPlatformHelper.java:608)
at com.xored.q7.launching.internal.target.TargetPlatformHelper.getDefaultProduct(TargetPlatformHelper.java:614)
at com.xored.q7.internal.launching.ext.ui.wizards.NewAUTPage.validatePlatform(NewAUTPage.java:162)
at com.xored.q7.internal.launching.ext.ui.wizards.NewAUTPage.access$4(NewAUTPage.java:141)
at com.xored.q7.internal.launching.ext.ui.wizards.NewAUTPage$9.handleChange(NewAUTPage.java:430)
at org.eclipse.core.databinding.observable.ChangeEvent.dispatch(ChangeEvent.java:41)
at org.eclipse.core.databinding.observable.ChangeManager.fireEvent(ChangeManager.java:119)
at org.eclipse.core.databinding.observable.AbstractObservable.fireChange(AbstractObservable.java:65)
at org.eclipse.core.databinding.observable.value.AbstractObservableValue.fireValueChange(AbstractObservableValue.java:70)
at org.eclipse.core.databinding.observable.value.WritableValue.doSetValue(WritableValue.java:92)
at org.eclipse.core.databinding.observable.value.AbstractObservableValue.setValue(AbstractObservableValue.java:55)
at com.xored.q7.internal.launching.ext.ui.wizards.NewAUTPage$1$1.run(NewAUTPage.java:133)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
... 47 more

Activity

Andrey Sobolev made changes - 26/Oct/12 7:35 PM
Field Original Value New Value
Fix Version/s 1.2.x [ 11172 ]
Fix Version/s 1.2.9 [ 11878 ]
Andrey Sobolev made changes - 30/Oct/12 9:23 AM
Assignee Sergey Sitnikov [ sergey ] Andrey Sobolev [ andrei.sobolev ]
Andrey Sobolev made changes - 30/Oct/12 9:23 AM
Status Open [ 1 ] In Progress [ 3 ]
Andrey Sobolev added a comment - 30/Oct/12 10:13 AM

Fixed.

Andrey Sobolev made changes - 30/Oct/12 10:13 AM
Resolution Fixed [ 1 ]
Status In Progress [ 3 ] Resolved [ 5 ]
Andrey Sobolev added a comment - 30/Oct/12 10:13 AM

Was only valid, then productId is not specified in .config file.

Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open In Progress In Progress
3d 19h 46m 1 Andrey Sobolev 30/Oct/12 9:23 AM
In Progress In Progress Resolved Resolved
49m 52s 1 Andrey Sobolev 30/Oct/12 10:13 AM

People

Vote (0)
Watch (0)

Dates

  • Created:
    26/Oct/12 2:36 PM
    Updated:
    30/Oct/12 10:13 AM
    Resolved:
    30/Oct/12 10:13 AM