Q7

Alt+Left click is recorded twice which makes test fail.

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Cannot Reproduce
  • Affects Version/s: 1.2.9
  • Fix Version/s: 1.2.11
  • Component/s: Recording
  • Labels:
  • Test Mode:
    Manual

Description

Use Eclipse 4.2.1 as AUT.

Import the attached test case, create a new one (using the same contexts) and try to record the following actions:

1. Open class1 editor;
2. Open class2 editor;
3. Make sure that class2 editor is active;
4. Press Alt+Left (=navigate Back);
5. Make sure that class1 editor is active.

Try to replay test case. It will fail because Alt+Left click has been recorded twice:

get-view "Package Explorer" | get-tree | select "MyProject/src/\\(default package\\)/Class1.java" | double-click
get-editor "Class1.java" | click
with [get-view "Package Explorer"] {
    click
    get-tree | select "MyProject/src/\\(default package\\)/Class2.java" | double-click
}
get-editor "Class2.java" | click
with [get-tab-folder -index 1] {
    get-property activePage | equals "Class2.java" | verify-true
    get-property tabCount | equals 2 | verify-true
}


get-eclipse-window | key-type "M3+ARROW_LEFT"
with [get-editor "Class1.java"] {
    click
    get-text-viewer | key-type "M3+ARROW_LEFT"
}
with [get-tab-folder -index 1] {
    get-property activePage | equals "Class1.java" | verify-true
    get-property tabCount | equals 2 | verify-true
}

Activity

komaz added a comment - 02/Nov/12 12:56 PM

Also it looks like there are unnecessary clicks recorded on views and editors

Andrey Sobolev added a comment - 15/Nov/12 12:47 PM

For Mac Key sequence are completely different: Cmd+[|Cmd+] for Left/right navigation.


People

Vote (0)
Watch (0)

Dates

  • Created:
    02/Nov/12 12:44 PM
    Updated:
    19/Nov/12 4:38 PM
    Resolved:
    19/Nov/12 4:38 PM