Q7

Q7 can't deal with AUT restart.

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.9
  • Fix Version/s: 1.2.9
  • Component/s: Runtime
  • Labels:
  • Test Mode:
    Manual

Description

When I record a test with File/Restart on e4 - it gives "Can't start ECL session" in recording mode and doesn't record "wait-until-eclipse-is-ready" command.
When I use Eclipse 3.7.2 it records "wait-until-eclipse-is-ready" but AUT is closed after restart and "Choose AUT" window is shown.

E4 Q7 NPE:

java.lang.NullPointerException
	at com.xored.tesla.recording.core.swt.SWTWidgetLocator.getEditorLocation(SWTWidgetLocator.java:1162)
	at com.xored.tesla.recording.core.swt.SWTWidgetLocator.findPartElement(SWTWidgetLocator.java:1124)

Activity

Andrey Sobolev added a comment - 02/Nov/12 2:02 PM

Fixed.

komaz added a comment - 02/Nov/12 7:17 PM

can't find a commit – what was the cause?

Andrey Sobolev added a comment - 04/Nov/12 8:57 PM

Only NPE was fixed.
I'm not intended to resolved it anyway, so I assume it was accidentally. So reopening. Thanks.

Andrey Sobolev added a comment - 06/Nov/12 2:38 PM

Support for 4x is committed, but still need to test on binary versions.

Andrey Sobolev added a comment - 07/Nov/12 10:39 AM

Fixed.

Ulyana Skorokhodova added a comment - 08/Nov/12 2:54 PM

verified


People

Vote (0)
Watch (0)

Dates

  • Created:
    02/Nov/12 1:44 PM
    Updated:
    08/Nov/12 2:54 PM
    Resolved:
    07/Nov/12 10:39 AM