Q7

Changes in Script editor broken a test

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.8
  • Fix Version/s: 1.2.12
  • Component/s: Recording, Runtime
  • Labels:
  • Test Mode:
    Manual

Description

One test consistently failing after recent changes - http://build.xored.com/browse/Q7-Q7D12-TSTSWIN-453/test/case/62653693
I was able to consistently reproduce it on Windows and was able to fix test by adding wait after type-text on line 5.
So it looks like Q7 does not wait for something and there are two options:

  1. something wrong in Q7 runtime and it may cause similar issues in other IDEs
  2. something wrong in our implementation of ECL editor

Please investigate and provide a feedback so that we can schedule a real fix for that. Priority is critical only for investigation

Activity

komaz added a comment - 08/Nov/12 11:20 AM

this can be a good starting point for reviewing and improving our completion recording, rescheduling to 1.2.10 and setting priority to 'major'

Andrey Sobolev added a comment - 14/Dec/12 2:08 PM

Seems fixed.


People

Vote (0)
Watch (0)

Dates

  • Created:
    07/Nov/12 7:35 PM
    Updated:
    14/Dec/12 2:08 PM
    Resolved:
    14/Dec/12 2:08 PM