Q7

Q7 Runner restarts AUT for no reason

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Cannot Reproduce
  • Affects Version/s: 1.2.9
  • Fix Version/s: 1.2.11
  • Component/s: Launching (Runtime)
  • Labels:
    None
  • Test Mode:
    Manual

Description

  1. Use http://github.com/xored/e4tests
  2. Run mvn clean package -f pom-runner.xml
  3. See the picture like this:
    [INFO] AUT-0:Launching
    [INFO] AUT-0:Product: org.eclipse.sdk.ide
    [INFO] AUT-0:Application: org.eclipse.ui.ide.workbench
    [INFO] AUT-0:Architecture: x86_64
    [INFO] 64bit arch is selected because AUT uses launcher library
    [INFO] 	"../../../plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.200.v20120522-1813" specified in config file: Eclipse.app/Contents/MacOS/eclipse.ini
    [INFO] /Users/ivaninozemtsev/work/q7/src-1.2/e4tests/E4 JDT Tests/target/aut-ws-0: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog
    [INFO] /Users/ivaninozemtsev/work/q7/src-1.2/e4tests/E4 JDT Tests/target/aut-ws-0: AUT VM arguments: -Xms40m -Xmx512m -Xdock:icon=../Resources/Eclipse.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -XX:MaxPermSize=128m
    [INFO] Fail 1 (41) processed. 1 failed. spent: 0:01, 0:13 mins remaining. Add Main Method During New Class Creation. time: 1396ms  Cause: Connection is not Available
    [INFO] Fail 2 (41) processed. 2 failed. spent: 0:02, 0:19 mins remaining. Add Remove Block Comment. time: 41ms  Cause: Connection is not Available
    [INFO] Fail 3 (41) processed. 3 failed. spent: 0:02, 0:14 mins remaining. Assign Statement to New Local Variable. time: 24ms  Cause: Connection is not Available
    [INFO] Fail 4 (41) processed. 4 failed. spent: 0:03, 0:18 mins remaining. Compress Package Names. time: 9ms  Cause: Connection is not Available
    [INFO] AUT-0:Restarting (restartId=1)
    [INFO] AUT-0:Product: org.eclipse.sdk.ide
    [INFO] AUT-0:Application: org.eclipse.ui.ide.workbench
    [INFO] AUT-0:Architecture: x86_64
    [INFO] 64bit arch is selected because AUT uses launcher library
    [INFO] 	"../../../plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.200.v20120522-1813" specified in config file: Eclipse.app/Contents/MacOS/eclipse.ini
    [INFO] /Users/ivaninozemtsev/work/q7/src-1.2/e4tests/E4 JDT Tests/target/aut-ws-0_restarted_1: AUT arguments: -os ${target.os} -arch ${target.arch} -nl ${target.nl} -consoleLog
    [INFO] /Users/ivaninozemtsev/work/q7/src-1.2/e4tests/E4 JDT Tests/target/aut-ws-0_restarted_1: AUT VM arguments: -Xms40m -Xmx512m -Xdock:icon=../Resources/Eclipse.icns -XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts -XX:MaxPermSize=128m
    [INFO] Fail 5 (41) processed. 5 failed. spent: 0:03, 0:15 mins remaining. Configure Project Layout. time: 34ms  Cause: Couldn't open ECL session
    [INFO] Fail 6 (41) processed. 6 failed. spent: 0:33, 2:20 mins remaining. Content Assist. time: 1412ms  Cause: Connection is not Available
    [INFO] Fail 7 (41) processed. 7 failed. spent: 0:34, 2:04 mins remaining. Copy Paste Method. time: 22ms  Cause: Connection is not Available
    

Activity

sergey added a comment - 14/Nov/12 5:42 PM

Have tested on my machine, there is no such problem, but where are couple of hangs, maybe they are somehow related to QS-2175:

[INFO] Pass 6 (41) processed. 0 failed. spent: 1:11, 5:01 mins remaining. Content Assist. time: 1068
8ms
[INFO] Pass 7 (41) processed. 0 failed. spent: 1:20, 4:53 mins remaining. Copy Paste Method. time: 8
382ms
[INFO] Pass 8 (41) processed. 0 failed. spent: 1:59, 6:20 mins remaining. Create Class With Extended
 Interface. time: 39337ms
[INFO] Fail 9 (41) processed. 1 failed. spent: 5:00, 14:05 mins remaining. Create Class With Supercl
ass. time: 180346ms  Cause: Context execution is terminated
[INFO]
[INFO]
[INFO] Possible AUT hang detected, 2 tests are failed because of timeout. Restarting AUT.
[INFO]

...

[INFO] Pass 21 (41) processed. 2 failed. spent: 10:11, 8:24 mins remaining. Delete Method in Package
 Explorer. time: 9897ms
[INFO] Pass 22 (41) processed. 2 failed. spent: 10:21, 7:45 mins remaining. Export Breakpoints. time
: 9962ms
[INFO] Pass 23 (41) processed. 2 failed. spent: 11:02, 7:30 mins remaining. Extended Interface. time
: 40921ms
[INFO] Fail 24 (41) processed. 3 failed. spent: 14:03, 8:38 mins remaining. Generate Comments. time:
 180801ms  Cause: Context execution is terminated

Seems like it gets stuck on same tests each time.

[INFO] Pass 6 (41) processed. 0 failed. spent: 1:11, 5:01 mins remaining. Content Assist. time: 1068
8ms
[INFO] Pass 7 (41) processed. 0 failed. spent: 1:20, 4:53 mins remaining. Copy Paste Method. time: 8
382ms
[INFO] Pass 8 (41) processed. 0 failed. spent: 1:59, 6:20 mins remaining. Create Class With Extended
 Interface. time: 39337ms
[INFO] Fail 9 (41) processed. 1 failed. spent: 5:00, 14:05 mins remaining. Create Class With Supercl
ass. time: 180346ms  Cause: Context execution is terminated
[INFO]
[INFO]
[INFO] Possible AUT hang detected, 2 tests are failed because of timeout. Restarting AUT.
[INFO]

...

[INFO] Pass 21 (41) processed. 2 failed. spent: 10:11, 8:24 mins remaining. Delete Method in Package
 Explorer. time: 9897ms
[INFO] Pass 22 (41) processed. 2 failed. spent: 10:21, 7:45 mins remaining. Export Breakpoints. time
: 9962ms
[INFO] Pass 23 (41) processed. 2 failed. spent: 11:02, 7:30 mins remaining. Extended Interface. time
: 40921ms
[INFO] Fail 24 (41) processed. 3 failed. spent: 14:03, 8:38 mins remaining. Generate Comments. time:
 180801ms  Cause: Context execution is terminated
Seems like it gets stuck on same tests each time.

People

Vote (0)
Watch (0)

Dates

  • Created:
    13/Nov/12 5:03 PM
    Updated:
    29/Nov/12 9:10 PM
    Resolved:
    29/Nov/12 9:10 PM