Q7

Nothing being recorded

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 1.2.9
  • Fix Version/s: 1.2.10
  • Component/s: Runtime
  • Test Mode:
    Manual

Description

After a couple of record and replays, we clicked "Record Snippet". Q7 Control Panel shows that recording is in progress, but no actions are recorded. Andrey Platov seen similar issues during ECE2012. Let's investigate any crazy idea why this can happen and prevent or at least extract a possible reason. Assume that AUT workspace log is not available.

Activity

Hide
komaz added a comment - 13/Nov/12 10:51 PM

Got an AUT error log. Completely no errors:

!SESSION 2012-11-13 11:33:06.540 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_21
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -data .\..\workspaces\pmmwb\default

!ENTRY org.eclipse.emf.ecore 2 0 2012-11-13 11:33:31.610
!MESSAGE Both 'com.fja.eos.chubb.ui' and 'com.fja.eos.chubb.ui.editor' register an extension parser for 'chubb'

!ENTRY org.eclipse.ui 4 4 2012-11-13 11:33:32.616
!MESSAGE Unable to find extension: com.fja.eos.ui.EOSPresentationFactory in extension point: presentationFactories

!ENTRY org.eclipse.ui 4 4 2012-11-13 11:33:32.620
!MESSAGE Error creating presentation factory: com.fja.eos.ui.EOSPresentationFactory -- class is not an AbstractPresentationFactory

!ENTRY org.eclipse.ui.navigator 4 0 2012-11-13 11:33:33.603
!MESSAGE An extension already exists with id "org.eclipse.ui.navigator.resourceContent".

!ENTRY org.eclipse.ui.navigator 4 0 2012-11-13 11:33:33.605
!MESSAGE An extension already exists with id "org.eclipse.ui.navigator.resources.workingSets".

Q7 error log is also fine

Show
komaz added a comment - 13/Nov/12 10:51 PM Got an AUT error log. Completely no errors:
!SESSION 2012-11-13 11:33:06.540 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_21
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Command-line arguments:  -os win32 -ws win32 -arch x86_64 -data .\..\workspaces\pmmwb\default

!ENTRY org.eclipse.emf.ecore 2 0 2012-11-13 11:33:31.610
!MESSAGE Both 'com.fja.eos.chubb.ui' and 'com.fja.eos.chubb.ui.editor' register an extension parser for 'chubb'

!ENTRY org.eclipse.ui 4 4 2012-11-13 11:33:32.616
!MESSAGE Unable to find extension: com.fja.eos.ui.EOSPresentationFactory in extension point: presentationFactories

!ENTRY org.eclipse.ui 4 4 2012-11-13 11:33:32.620
!MESSAGE Error creating presentation factory: com.fja.eos.ui.EOSPresentationFactory -- class is not an AbstractPresentationFactory

!ENTRY org.eclipse.ui.navigator 4 0 2012-11-13 11:33:33.603
!MESSAGE An extension already exists with id "org.eclipse.ui.navigator.resourceContent".

!ENTRY org.eclipse.ui.navigator 4 0 2012-11-13 11:33:33.605
!MESSAGE An extension already exists with id "org.eclipse.ui.navigator.resources.workingSets".
Q7 error log is also fine
Hide
Andrey Sobolev added a comment - 15/Nov/12 11:55 AM

Seems fixed.

Show
Andrey Sobolev added a comment - 15/Nov/12 11:55 AM Seems fixed.

People

Vote (0)
Watch (0)

Dates

  • Created:
    13/Nov/12 10:46 PM
    Updated:
    15/Nov/12 11:55 AM
    Resolved:
    15/Nov/12 11:55 AM