Q7

Q7 cannot deal with graphiti example

Details

  • Type: Bug Bug
  • Status: Reopened Reopened
  • Priority: Major Major
  • Resolution: Unresolved
  • Affects Version/s: 1.2.10
  • Fix Version/s: 1.3.x
  • Component/s: Recording, Runtime
  • Labels:
    None
  • Test Mode:
    Manual

Description

Graphiti example diagram allows to draws eclasses and connect them with links. Drawing links is not being recorded correctly. Most likely the same issue prevented correct working with Christian's AUT

Activity

komaz added a comment - 27/Nov/12 4:29 PM

Reopening since ocassionally recorded scripts cannot be replayed.
Andrey, could you take a look, as it seems you can reproduce issues easier.
What I have found so far is that it seems that floating figure with actions might not appear during replay in script like this:

get-edit-part foo | mouse-move // shows "toolbar"
get-edit-part bar | mouse-move // hides "toolbar" from foo,  
                      //but does not show it on bar
// adding this line manually fixes script:
get-edit-part bar | mouse-move // shows bar toolbar

However, script like above cannot be recorded "as is", since we would remove the mouse move from "foo" because of QS-2211 fix

get-edit-part foo | mouse-move // shows "toolbar"
get-edit-part bar | mouse-move // hides "toolbar" from foo,  
                      //but does not show it on bar
// adding this line manually fixes script:
get-edit-part bar | mouse-move // shows bar toolbar
However, script like above cannot be recorded "as is", since we would remove the mouse move from "foo" because of QS-2211 fix
Andrey Sobolev made changes - 16/Jan/13 3:47 PM
Fix Version/s 1.2.15 [ 11972 ]
Fix Version/s Future [ 10141 ]
Andrey Sobolev made changes - 16/Jan/13 5:48 PM
Fix Version/s Future [ 10141 ]
Fix Version/s 1.3.x [ 11471 ]
Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open Resolved Resolved
2d 17h 30m 1 komaz 22/Nov/12 1:37 PM
Resolved Resolved Reopened Reopened
5d 2h 52m 1 komaz 27/Nov/12 4:29 PM

People

Vote (0)
Watch (0)

Dates

  • Created:
    19/Nov/12 8:07 PM
    Updated:
    16/Jan/13 5:48 PM