Q7

Collapse consequent mouse moves on edit parts

Details

  • Type: Improvement Improvement
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.11
  • Fix Version/s: 1.2.11
  • Component/s: Recording
  • Labels:
    None
  • Test Mode:
    Manual

Description

take a graphiti chess example, start recording and move a mouse over a board. Script like this will be recorded:

    get-edit-part -className ContainerShapeEditPart -index 9 | mouse-move 15 43 -height 50 -width 50
    get-edit-part -className ContainerShapeEditPart -index 10 | mouse-move 17 45 -height 50 -width 50
    get-edit-part -className ContainerShapeEditPart -index 9 | mouse-move 43 1 -height 50 -width 50
    get-edit-part -className ContainerShapeEditPart -index 8 | mouse-move 12 38 -height 50 -width 50
    get-edit-part -className ContainerShapeEditPart -index 16 | mouse-move 48 40 -height 50 -width 50
    ...
    get-edit-part -className ContainerShapeEditPart -index 20 | mouse-move 41 8 -height 50 -width 50
    get-edit-part -className ContainerShapeEditPart -index 12 | mouse-move 39 41 -height 50 -width 50
    get-edit-part -className ContainerShapeEditPart -index 11 | mouse-move 40 17 -height 50 -width 50
    get-edit-part -className ContainerShapeEditPart -index 8 | mouse-move 13 20 -height 50 -width 50

Though all boards cells and pieces have mouse motion listeners, I did not yet performed any useful action. Let us implement the following heuristics:
When we have two consequent mouse moves, even on different edit parts, we should leave only the latest one.

Please leave a comment if you know an example when this heuristics won't work.

Activity

komaz added a comment - 26/Nov/12 6:05 PM

Andrey, please take a look at branch {{jira/QS-2211}}. Looks like element ids are not remapped somewhere, as I get code like this at some point:

control-not-found | mouse-move ...
control-not-found | mouse-move ...
komaz added a comment - 26/Nov/12 7:22 PM

Looks like all issues are done, please merge into dev-1.2 if code is ok

Andrey Sobolev added a comment - 27/Nov/12 10:27 AM

Looks, Ok, but figure mouse-move's are not collapsed.

get-figure "1/0" | mouse-move 218 18 -mask 524288 -height 20 -width 218
get-figure "1/0" | mouse-move 219 18 -mask 524288 -height 20 -width 220
get-figure "1/0" | mouse-move 220 18 -mask 524288 -height 20 -width 221
get-figure "1/0" | mouse-move 220 16 -mask 524288 -height 20 -width 222

Andrey Sobolev added a comment - 27/Nov/12 10:29 AM

q7 projects with 4 samples recorded:

One one is working

1,3 - recorded with duplicate mouse-move enabled
2 - with duplicate disabled
4 - with dev-1.2 current code

Andrey Sobolev added a comment - 27/Nov/12 10:29 AM

1 - one, seems to miss some mouse-move, or it could be a graphiti issue.

komaz added a comment - 27/Nov/12 3:03 PM

figure mouse moves collapsing is out of scope of issue, issue with replay also is not caused by this one, so merging and resolving


People

  • Assignee:
    komaz
    Reporter:
    komaz
Vote (0)
Watch (0)

Dates

  • Created:
    22/Nov/12 6:13 PM
    Updated:
    27/Nov/12 3:03 PM
    Resolved:
    27/Nov/12 3:03 PM