Q7

Add a preference for ECL content assist autoactivation.

Details

  • Type: Improvement Improvement
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.11
  • Fix Version/s: 1.2.23, 1.3.6
  • Component/s: UI
  • Labels:
    None
  • Test Mode:
    Q7

Description

It would be nice if we had a preference to enable/disable content assist autoactivation.

Activity

Andrey Sobolev made changes - 16/Jan/13 5:55 PM
Fix Version/s 1.2.x [ 11172 ]
Fix Version/s 1.3.x [ 11471 ]
komaz added a comment - 01/Aug/13 3:00 PM - edited

We need a page similar to Window -> Preferences -> Java -> Editor -> Content Assist (bottom group, Auto Activation), but for ECL. Later we can incorporate other settings like syntax coloring under ECL node.

Ulyana Skorokhodova added a comment - 02/Aug/13 3:53 PM

Need to disable 'Delay' and 'Triggers' controls when Autoactivation is switched off.

Ulyana Skorokhodova made changes - 02/Aug/13 3:53 PM
Status Resolved [ 5 ] Reopened [ 4 ]
Resolution Fixed [ 1 ]
komaz added a comment - 02/Aug/13 4:01 PM

Two more notes:

  1. Content assist preference page should be moved under 'Q7' for now
  2. Storing these preferences in Q7 launching plugin makes no sense – q7.launching has no relation to completion and also this creates dependency from EclEditor class to Q7Launcher class
  1. Content assist preference page should be moved under 'Q7' for now
  2. Storing these preferences in Q7 launching plugin makes no sense – q7.launching has no relation to completion and also this creates dependency from EclEditor class to Q7Launcher class
Ulyana Skorokhodova added a comment - 05/Aug/13 3:40 PM

"Restore defaults" doesn't make fields enabled.

Steps to reproduce:

1) Open Q7/Content Assist preference page;
2) Uncheck "Enable Auto Activation";
3) Press "Restore Defaults" button;
Bug: "Enable Auto Activation" became enabled but Delay and Trigger fields are still disabled.

Ulyana Skorokhodova made changes - 05/Aug/13 3:40 PM
Status Resolved [ 5 ] Reopened [ 4 ]
Resolution Fixed [ 1 ]
Ulyana Skorokhodova made changes - 05/Aug/13 4:46 PM
Test Mode Manual Q7
mikayel.nersisyan added a comment - 16/Aug/13 5:07 PM

Restore Defaults functionality now works as intended.

Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open Resolved Resolved
246d 5h 5m 1 mikayel.nersisyan 01/Aug/13 7:46 PM
Resolved Resolved Reopened Reopened
3d 14h 17m 2 Ulyana Skorokhodova 05/Aug/13 3:40 PM
Reopened Reopened Resolved Resolved
11d 7h 3m 2 mikayel.nersisyan 16/Aug/13 5:07 PM