Q7

Q7 can't replay 'get-view' command if view contains ":" in its name.

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.10
  • Fix Version/s: 1.2.12
  • Component/s: Runtime
  • Labels:
    None
  • Test Mode:
    Manual

Activity

komaz added a comment - 30/Nov/12 12:51 PM

Where can we find such a view for testing?

Andrey Sobolev added a comment - 12/Dec/12 10:43 AM

Seems this issue is also causing:

Hi Ivan,
I prepared a minimal test case for the problem of selecting views with slashes inside. 
I attached the test case. 
You can try it out with the latest ECP version from here: 
https://hudson.eclipse.org/hudson/job/emf-emfclient-maintenance/lastSuccessfulBuild/artifact/git/ECP2/org.eclipse.emf.ecp.products/target/products/

Jonas also has Q7 tests that fail due to Q7 which can be reproduced with ECP. I will send a separate EMail tomorrow about how to get them. 

Cheers,
Eugen
Hi Ivan,
I prepared a minimal test case for the problem of selecting views with slashes inside. 
I attached the test case. 
You can try it out with the latest ECP version from here: 
https://hudson.eclipse.org/hudson/job/emf-emfclient-maintenance/lastSuccessfulBuild/artifact/git/ECP2/org.eclipse.emf.ecp.products/target/products/

Jonas also has Q7 tests that fail due to Q7 which can be reproduced with ECP. I will send a separate EMail tomorrow about how to get them. 

Cheers,
Eugen
Andrey Sobolev added a comment - 12/Dec/12 10:46 AM

Fixed.


People

Vote (0)
Watch (0)

Dates

  • Created:
    30/Nov/12 12:21 PM
    Updated:
    12/Dec/12 10:46 AM
    Resolved:
    12/Dec/12 10:46 AM