Q7

Target platform is not valid then Q7 Agent is try to launch AUT

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Critical Critical
  • Resolution: Fixed
  • Affects Version/s: 1.2.11
  • Fix Version/s: 1.2.12
  • Component/s: Launching (Runtime)
  • Labels:
    None
  • Test Mode:
    Manual

Description

There is a lot of same problems in agents right now:

2012/12/07 10:54:10: error from agent: tcp://192.168.4.140:4000 msg: Exception during test execution: exception: Target platform validation error:Error reading manifest for C:\agent\agent-ws\.metadata\.plugins\org.eclipse.pde.core\.bundle_pool\plugins\org.aspectj.runtime_1.7.0.20120703164200

org.eclipse.core.runtime.CoreException: Target platform validation error:Error reading manifest for C:\agent\agent-ws\.metadata\.plugins\org.eclipse.pde.core\.bundle_pool\plugins\org.aspectj.runtime_1.7.0.20120703164200

	at com.xored.q7.cloud.agent.AgentPlugin.createException(AgentPlugin.java:63)
	at com.xored.q7.cloud.agent.AutRegistry$1.run(AutRegistry.java:197)
	at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.Exception
	at com.xored.q7.cloud.agent.AutRegistry$1.run(AutRegistry.java:200)
	... 1 more

Seems issue is caused by P2,
it could not download some files, we not check for such situations.
So need to investigate how to catch this situation, and how to force p2 try to fetch files one more time.

Activity

Andrey Sobolev added a comment - 07/Dec/12 11:31 AM

Build is failed because of this issue: http://build.xored.com/browse/Q7-Q7D12-DFTGR-533

Andrey Sobolev added a comment - 11/Dec/12 6:48 PM

Seems fixed.


People

Vote (0)
Watch (0)

Dates

  • Created:
    07/Dec/12 11:30 AM
    Updated:
    11/Dec/12 6:48 PM
    Resolved:
    11/Dec/12 6:48 PM