Q7

Unable to add link into service flow by clicking on it on diagram

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Cannot Reproduce
  • Affects Version/s: 1.2.10
  • Fix Version/s: 1.2.17
  • Component/s: Launching (Runtime)
  • Labels:
  • Test Mode:
    Q7
  • Q7 test:
    VZ-1717_BER diagram deleting links does not delete associated service flows

Description

Steps to reproduce

  1. Use workspace attached, start recording
  2. Open sample1
  3. Click on Service Flow in palette
  4. Select a link by clicking on it on diagram
  5. Try to replay

Script

with [get-editor sample1] {
    with [get-palette | get-palette-entry "Service Flow"] {
        mouse-move 58 5 button1 -height 22 -width 120
        mouse-press 58 5 button1 -height 22 -width 120
        mouse-release 58 5 button1 524288 -height 22 -width 120
    }
    with [get-diagram -index 1 | get-edit-part -name sample1 | get-edit-part -className PlatformPart | get-edit-part 
        -className SubPlatformPart | get-edit-part -name "Manage Logical Inventory" | get-target-connection 0] {
        mouse-move 71 132 button1 -height 175 -width 324
        mouse-press 71 132 button1 -height 175 -width 324
        mouse-hover 71 132 -height 175 -width 324
        mouse-move 70 132 -height 175 -width 324
    }
}
get-window "New Service Flow" | get-button OK | click

fails with The control "OK" is disabled., because link wasn't selected

Activity

There are no comments yet on this issue.

People

  • Assignee:
    sergey
    Reporter:
    lena.platova
Vote (0)
Watch (0)

Dates

  • Created:
    07/Dec/12 3:52 PM
    Updated:
    27/Aug/13 6:53 PM
    Resolved:
    27/Aug/13 6:53 PM