Q7

If one of Agents can't download AUT because of network problems, it will continue taking and failing tests.

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.12
  • Fix Version/s: 1.2.14
  • Component/s: Server
  • Labels:
    None
  • Test Mode:
    Manual

Description

Need to disable agent from suite execution, since it can't download AUT.

2012/12/20 14:38:38: #################### Initialize execution session
2012/12/20 14:42:14: error from agent: tcp://192.168.4.132:4000 msg: Exception during test execution: exception: AUT download failed
org.eclipse.core.runtime.CoreException: AUT download failed
	at com.xored.q7.cloud.agent.AgentPlugin.createException(AgentPlugin.java:63)
	at com.xored.q7.cloud.agent.autManager.impl.BaseAutProvider.download(BaseAutProvider.java:154)
	at com.xored.q7.cloud.agent.AutRegistry$1.run(AutRegistry.java:78)
	at java.lang.Thread.run(Thread.java:662)
Caused by: java.io.IOException: Cannot download from http://maven.xored.com/nexus/content/repositories/thirdparty/eclipse/tigerstripe/0.7.0/tigerstripe-0.7.0-win32.win32.x86.zip
	at com.xored.q7.cloud.util.IOUtil.downloadSafe(IOUtil.java:343)
	at com.xored.q7.cloud.util.IOUtil.download(IOUtil.java:253)
	at com.xored.q7.cloud.agent.autManager.impl.BaseAutProvider.download(BaseAutProvider.java:83)
	... 2 more
Caused by: java.net.UnknownHostException: maven.xored.com
	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:195)
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
	at java.net.Socket.connect(Socket.java:529)
	at java.net.Socket.connect(Socket.java:478)
	at sun.net.NetworkClient.doConnect(NetworkClient.java:163)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)
	at sun.net.www.http.HttpClient.<init>(HttpClient.java:233)
	at sun.net.www.http.HttpClient.New(HttpClient.java:306)
	at sun.net.www.http.HttpClient.New(HttpClient.java:323)
	at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:970)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:911)
	at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:836)
	at com.xored.q7.cloud.util.IOUtil$HttpSrc.reopen(IOUtil.java:149)
	at com.xored.q7.cloud.util.IOUtil.downloadSafe(IOUtil.java:282)
	... 4 more

2012/12/20 14:42:41: error from agent: tcp://192.168.4.132:4000 msg: Exception during test execution: exception: AUT download failed
org.eclipse.core.runtime.CoreException: AUT download failed
	at com.xored.q7.cloud.agent.AgentPlugin.createException(AgentPlugin.java:63)
	at com.xored.q7.cloud.agent.autManager.impl.BaseAutProvider.download(BaseAutProvider.java:154)
	at com.xored.q7.cloud.agent.AutRegistry$1.run(AutRegistry.java:78)
	at java.lang.Thread.run(Thread.java:662)
Caused by: java.io.IOException: Cannot download from http://maven.xored.com/nexus/content/repositories/thirdparty/eclipse/sdk/3.7.0/sdk-3.7.0-win32.win32.x86.zip
	at com.xored.q7.cloud.util.IOUtil.downloadSafe(IOUtil.java:343)
	at com.xored.q7.cloud.util.IOUtil.download(IOUtil.java:253)
	at com.xored.q7.cloud.agent.autManager.impl.BaseAutProvider.download(BaseAutProvider.java:83)
	... 2 more
Caused by: java.net.UnknownHostException: maven.xored.com
	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:195)
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
	at java.net.Socket.connect(Socket.java:529)
	at java.net.Socket.connect(Socket.java:478)
	at sun.net.NetworkClient.doConnect(NetworkClient.java:163)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)
	at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)
	at sun.net.www.http.HttpClient.<init>(HttpClient.java:233)
	at sun.net.www.http.HttpClient.New(HttpClient.java:306)
	at sun.net.www.http.HttpClient.New(HttpClient.java:323)
	at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:970)
	at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:911)
	at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:836)
	at com.xored.q7.cloud.util.IOUtil$HttpSrc.reopen(IOUtil.java:149)
	at com.xored.q7.cloud.util.IOUtil.downloadSafe(IOUtil.java:282)
	... 4 more

Activity

Andrey Sobolev added a comment - 16/Jan/13 11:53 AM

Fixed.


People

Vote (0)
Watch (0)

Dates

  • Created:
    20/Dec/12 2:59 PM
    Updated:
    16/Jan/13 11:53 AM
    Resolved:
    16/Jan/13 11:53 AM