Q7

check/uncheck fail on customer's tree and underlying reason is not reported properly

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.12
  • Fix Version/s: 1.2.17
  • Component/s: Runtime
  • Labels:
  • Test Mode:
    Manual
  • Q7 test:
    QS_2309_CheckboxTree

Description

Customer observes an error:

Execution failed on line 2 at column 37 (Constraint Explorer.test:2)
Caused by:
        Cannot check item(s)

Looking at the code of ActionService#handleCheck it looks like an error from BooleanResponse#getMessage might be not set or not logged properly. Need to investigate possible execution paths and make sure we return additional information (like item does not exist) and log exceptions raised.

If we do it, then even if AUT does not have a log file, we can always ask to add "-consoleLog" arg and enable console in AUT configuration and get logged entries in Console view of Q7 IDE.

From the customer:

1) If the box is checked and I try to uncheck it:

Here is the ECL script produced:

with [get-view Constraints | get-tree] {
    get-item "Static Constraints" | uncheck
    select "Static Constraints"
}

When I replay the script, nothing happens.

2) If the box is checked and I edited the ECL script produced and changed it to also check it again:

Here is the ECL script after editing:

with [get-view Constraints | get-tree] {
    get-item "Static Constraints" | check
    select "Static Constraints"
}

I get the following:
Execution failed on line 2 at column 37 (Constraint Explorer.test:2)
Caused by:
Cannot check item(s)

3) If the box is unchecked and I try to check it I get the same above error.

More information on this issue is available in q7 mailing list with a subject "A problem with checking and unchecking checkboxes in a certain view".

Activity

sergey added a comment - 12/Feb/13 10:37 PM

Finally resolved!

anastasia.ahramenko added a comment - 21/Mar/13 5:20 PM

Test is added to Quality Tests on build system.


People

  • Assignee:
    sergey
    Reporter:
    komaz
Vote (0)
Watch (0)

Dates

  • Created:
    03/Jan/13 11:14 PM
    Updated:
    21/Mar/13 5:20 PM
    Resolved:
    12/Feb/13 10:37 PM

Time Tracking

Estimated:
2h
Original Estimate - 2 hours
Remaining:
2h
Remaining Estimate - 2 hours
Logged:
Not Specified
Time Spent - Not Specified