Q7

Tests on MLI elements in Vozone are unstable

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.16
  • Fix Version/s: 1.2.16
  • Component/s: Runtime
  • Labels:
    None
  • Test Mode:
    Q7

Description

The following tests on Vozone are unstable:

  • Fragmented import MLI (link after network elements)
  • MLI import after generating
  • Import generated MLI to created diagram
  • MLI import (link after Network Elements)
  • MLI import (link after Network Elements, link's ends unbinded)
  • Fragmented import MLI (network elements with the same name)

Activity

Andrey Sobolev added a comment - 24/Jan/13 4:18 PM
  • Fragmented import MLI (network elements with the same name) - is failed because following ecl code is executed not correctly:
with [get-editor Diagram | get-diagram] {
    with [get-edit-part -name Diagram] {
        mouse-move 136 398 button3 -height 609 -width 1034
        mouse-press 136 398 button3 -height 609 -width 1034
        mouse-release 136 398 button3 2097152 -height 609 -width 1034
    }
    get-menu "Import MLI..." | click
}

It should press somethere in empty space of diagramm, but select some child item. But child item doesn't have menu.

  • Fragmented import MLI (network elements with the same name) - is failed because following ecl code is executed not correctly:
with [get-editor Diagram | get-diagram] {
    with [get-edit-part -name Diagram] {
        mouse-move 136 398 button3 -height 609 -width 1034
        mouse-press 136 398 button3 -height 609 -width 1034
        mouse-release 136 398 button3 2097152 -height 609 -width 1034
    }
    get-menu "Import MLI..." | click
}
It should press somethere in empty space of diagramm, but select some child item. But child item doesn't have menu.
Andrey Sobolev added a comment - 25/Jan/13 4:43 PM

Fixed.

Anastasia could you please verify it.
Thanks.
Build http://build.xored.com/browse/Q7-Q7D12-DFTGR-696 contains fix.

Also please enable appropriate tests in Q7 vozone dogfood.

anastasia.ahramenko added a comment - 07/Feb/13 11:07 AM

Verified, problem is not reproduced.
All appropriate tests were added to Vozone dogfood again.


People

Vote (0)
Watch (0)

Dates

  • Created:
    24/Jan/13 4:15 PM
    Updated:
    07/Feb/13 11:07 AM
    Resolved:
    25/Jan/13 4:43 PM