Q7

Timeout during test execution on big amount of tests.

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.16
  • Fix Version/s: 1.2.17
  • Component/s: Runtime
  • Labels:
    None
  • Test Mode:
    Manual

Description

When a large number of tests performed sequentially by Q7, then after 400-500 tests Q7 slowly executes tests.
And tests, execution which usually takes 1-2 minutes, is executed more than 5 minutes.

For example, the such tests in Vozone:
VZ-1346_VZ-1389_Import multiple devices from MRSPEC xml&Create a folder structure for usages
Link helper for definitions in subfolders (collapsed folders)
MRSpec Import

Activity

Andrey Sobolev added a comment - 30/Jan/13 9:39 AM

During replay there Q7 is not correctly clear ITeslaCommandProcessor based classes.
So for each test we have instance of SWTUIProcessor etc.
Because of this a lot of different classes are used on replay of each next test.

Andrey Sobolev added a comment - 04/Feb/13 9:39 AM

Original issue is fixed. Now there is no execution slowdown, fix is available for version 1.2.16.

Andrey Sobolev added a comment - 14/Feb/13 2:11 PM

Assume as fixed.

anastasia.ahramenko added a comment - 19/Mar/13 6:43 AM

Problem is not reproduced.


People

Vote (0)
Watch (0)

Dates

  • Created:
    25/Jan/13 3:30 PM
    Updated:
    19/Mar/13 6:43 AM
    Resolved:
    14/Feb/13 2:11 PM