Q7

Vozone test is failed because moving on diagram is executed incorrectly

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Minor Minor
  • Resolution: Fixed
  • Affects Version/s: 1.2.16
  • Fix Version/s: 1.2.17
  • Component/s: None
  • Labels:
  • Test Mode:
    Q7
  • Q7 test:
    MoveMessageEndpointToNewLifeline

Description

"MoveMessageEndpointToNewLifeline" vozone test is failed in build system since from http://build.xored.com/browse/VSD-VSDTRUNK-Q7W32-3224/
Error is reproduced on the local machine:
Execution failed on line 67 at column 71
Caused by:
Assertion of getModel().getChildren().isEmpty() failed: expected:<true> but was:<false>.

Assertion is failed because element on diagram was not moved.

Activity

anastasia.ahramenko added a comment - 13/Feb/13 3:10 PM

May be the following tests are crashed by this problem:

  • AutoNumberingOnMessageLink
  • MessageIsDeletedAfterInstanceDeletion
  • AutoNumberingIsPreservedAfterClosingDiagramOrProject
  • DocumentationTabForSD

Problem occurs on the Sequence Diagram.

  • AutoNumberingOnMessageLink
  • MessageIsDeletedAfterInstanceDeletion
  • AutoNumberingIsPreservedAfterClosingDiagramOrProject
  • DocumentationTabForSD
Problem occurs on the Sequence Diagram.
lena.platova added a comment - 13/Feb/13 3:24 PM - edited

IMO tests

  • AutoNumberingOnMessageLink
  • AutoNumberingIsPreservedAfterClosingDiagramOrProject
  • MessageIsDeletedAfterInstanceDeletion

fail because of small window size (can strongly reproduce it locally). Reason is Failed to locate the figure by classname: ActivationEditPart by index:

BTW there is no moving on diagram in test "DocumentationTabForSD" and it works correctly for me

  • AutoNumberingOnMessageLink
  • AutoNumberingIsPreservedAfterClosingDiagramOrProject
  • MessageIsDeletedAfterInstanceDeletion
fail because of small window size (can strongly reproduce it locally). Reason is Failed to locate the figure by classname: ActivationEditPart by index: BTW there is no moving on diagram in test "DocumentationTabForSD" and it works correctly for me
ekoshelko added a comment - 25/Feb/13 1:23 PM

There is also bug if i change aut window size:

Execution failed on line 36 at column 5 (MoveMessageEndpointToNewLifeline.test:36)
Caused by:
Failed to locate the figure by classname: ActivationEditPart by index: 3.

ekoshelko added a comment - 25/Feb/13 5:53 PM

Bug with changing window size occurs only when scroll bars is shown.

ekoshelko added a comment - 27/Feb/13 12:04 PM - edited

Bug happens because GefProcessor.correctFigurePosition works wrong and changes mouse-drag coords.

In version 1.2.14 test pass. But in 1.2.16+ in scenario writed extra path to elemnt (Possible this is prolem).

This script writed in 1.2.14 when starting drag arrow.

with [get-edit-part -className InteractionEditPart | get-edit-part -className ActivationEditPart -index 3]

This in 1.2.17:

with [get-edit-part -className InteractionEditPart | get-edit-part -className ActivationEditPart -index 3 | get-target-connection 0 | get-handle ConnectionEndpointHandle -index 1] {
with [get-edit-part -className InteractionEditPart | get-edit-part -className ActivationEditPart -index 3]
This in 1.2.17:
with [get-edit-part -className InteractionEditPart | get-edit-part -className ActivationEditPart -index 3 | get-target-connection 0 | get-handle ConnectionEndpointHandle -index 1] {
komaz added a comment - 01/Mar/13 9:08 AM

We suspect that in passes in 1.2.14 because of mutual record/replay bug. Could you try to recreate these tests with 1.2.17 and check whether it works?


People

  • Assignee:
    lena.platova
    Reporter:
    anastasia.ahramenko
Vote (0)
Watch (0)

Dates

  • Created:
    31/Jan/13 5:17 PM
    Updated:
    27/Aug/13 9:38 PM
    Resolved:
    27/Aug/13 9:38 PM