Q7

Q7 Cloud OutOfMemory issue.

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.17
  • Fix Version/s: 1.2.17
  • Component/s: None
  • Labels:
    None
  • Test Mode:
    Manual

Description

Need to profile Q7 server and fix leaks.

!ENTRY org.eclipse.ecl.core 4 0 2013-02-04 10:24:56.747
!MESSAGE Java heap space
!STACK 1
org.eclipse.core.runtime.CoreException: Java heap space
        at org.eclipse.ecl.internal.core.EMFStreamPipe.take(EMFStreamPipe.java:116)
        at org.eclipse.ecl.server.tcp.SessionRequestHandler.run(SessionRequestHandler.java:38)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.OutOfMemoryError: Java heap space
!SUBENTRY 1 org.eclipse.ecl.core 4 0 2013-02-04 10:24:56.747
!MESSAGE Java heap space
!STACK 0
java.lang.OutOfMemoryError: Java heap space

Activity

Andrey Sobolev added a comment - 19/Feb/13 1:06 PM

Profiling sessions doesn't show any leaks.
So postponing.

Andrey Sobolev added a comment - 19/Feb/13 4:47 PM

Looks like issue is related to improper use of ISMHandle.apply() with model modification.

Following class com.xored.q7.cloud.server.rest.internal.StatsHandler.handle(String, Request, HttpServletRequest, HttpServletResponse)
is duing modications but doesn't save content.

Andrey Sobolev added a comment - 20/Feb/13 3:32 PM

Fixed.


People

Vote (0)
Watch (0)

Dates

  • Created:
    04/Feb/13 10:35 AM
    Updated:
    20/Feb/13 3:32 PM
    Resolved:
    20/Feb/13 3:32 PM