Q7

Background colors assert fail.

Details

  • Test Mode:
    Manual

Description

Hey guys, C/P from customer email:

I have a note related to the 1.2.17-RC1 version:
When I try to dump background colors using 1.2.17-RC1 (either the IDE or the runner), I get different values than 1.2.15.
I think that the older values are correct (You can check that from the Screenshot attached).
Here is the command:

format "dynamic constraint c1: Background Color: %.0s%.0s%s" [get-edit-part -className GraphModelBodyPart | get-edit-part -className RepeatPart | get-edit-part -className RepeatBodyPart | get-edit-part -text c1 | get-property backgroundColor -raw | print | foreach -do {echo}]

And here are the results produced by the different runners (IDEs):
1.2.15:

0 227 233 237

1.2.17-RC1:

0 99 99 0

Please could you check that issue.

I have a screenshot confirming that 1.2.15 return correct numbers.

Activity

Andrey Sobolev made changes - 05/Feb/13 5:53 AM
Field Original Value New Value
Component/s Runtime [ 10010 ]
Assignee Ivan Inozemtsev [ komaz ] Sergey Sitnikov [ sergey ]
Labels customer mina customer mina regression
Summary [regression?] Background colors Background colors assert fail.
Andrey Platov made changes - 05/Feb/13 12:38 PM
Attachment Screenshot.png [ 13142 ]
sergey added a comment - 05/Feb/13 1:27 PM

Won't fix since old behavior is erroneous.

Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open Resolved Resolved
13h 50m 1 sergey 05/Feb/13 1:27 PM