Q7

Graphiti chess example does not work in Q7 1.2.17

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Cannot Reproduce
  • Affects Version/s: 1.2.17
  • Fix Version/s: 1.2.17
  • Component/s: Runtime
  • Labels:
    None
  • Test Mode:
    Manual

Description

  • 1.2.17 from sources
    • Figure moves recorded as drags on canvas
    • Replay throws error:
         com.xored.tesla.internal.core.TeslaExecutionFailedException: com.xored.tesla.internal.ui.processors.DragSupport.handleUniversalDrag:125
      	at com.xored.tesla.internal.ui.player.SWTUIPlayer$8.run(SWTUIPlayer.java:2686)
      	at org.eclipse.swt.widgets.RunnableLock.run_aroundBody0(RunnableLock.java:35)
      	at org.eclipse.swt.widgets.RunnableLock$AjcClosure1.run(RunnableLock.java:1)
      	at com.xored.tesla.swt.aspects.DisplayAspect.ajc$around$com_xored_tesla_swt_aspects_DisplayAspect$10$90b1ba39proceed(DisplayAspect.aj:1)
      	at com.xored.tesla.swt.aspects.DisplayAspect.ajc$around$com_xored_tesla_swt_aspects_DisplayAspect$10$90b1ba39(DisplayAspect.aj:342)
      	at org.eclipse.swt.widgets.RunnableLock.run_aroundBody2(RunnableLock.java:35)
      	at org.eclipse.swt.widgets.RunnableLock$AjcClosure3.run(RunnableLock.java:1)
      	at com.xored.sherlock.aspects.swt.DisplayAspect.ajc$around$com_xored_sherlock_aspects_swt_DisplayAspect$2$90b1ba39proceed(DisplayAspect.aj:1)
      	at com.xored.sherlock.aspects.swt.DisplayAspect.ajc$around$com_xored_sherlock_aspects_swt_DisplayAspect$2$90b1ba39(DisplayAspect.aj:60)
      	at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
      	at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:135)
      	at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3938)
      	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615)
      	at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2696)
      	at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2660)
      	at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2494)
      	at org.eclipse.ui.internal.Workbench$7.run(Workbench.java:674)
      	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
      	at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:667)
      	at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
      	at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:123)
      	at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
      	at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:344)
      	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:622)
      	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:577)
      	at org.eclipse.equinox.launcher.Main.run(Main.java:1410)
      	at org.eclipse.equinox.launcher.Main.main(Main.java:1386)
      Caused by: java.lang.IllegalArgumentException: CreateRequest has unspecified CreationFactory
      	at org.eclipse.gef.requests.CreateRequest.getNewObject(CreateRequest.java:76)
      	at org.eclipse.graphiti.ui.internal.policy.ShapeXYLayoutEditPolicy.getCreateCommand(ShapeXYLayoutEditPolicy.java:437)
      	at org.eclipse.gef.editpolicies.LayoutEditPolicy.getCommand(LayoutEditPolicy.java:228)
      	at org.eclipse.gef.editpolicies.ConstrainedLayoutEditPolicy.getCommand(ConstrainedLayoutEditPolicy.java:214)
      	at org.eclipse.gef.editparts.AbstractEditPart.getCommand(AbstractEditPart.java:502)
      	at org.eclipse.gef.dnd.AbstractTransferDropTargetListener.getCommand(AbstractTransferDropTargetListener.java:215)
      	at org.eclipse.gef.dnd.AbstractTransferDropTargetListener.isEnabled(AbstractTransferDropTargetListener.java:403)
      	at org.eclipse.jface.util.DelegatingDropAdapter.updateCurrentListener(DelegatingDropAdapter.java:365)
      	at org.eclipse.jface.util.DelegatingDropAdapter.drop(DelegatingDropAdapter.java:207)
      	at org.eclipse.swt.dnd.DNDListener.handleEvent(DNDListener.java:90)
      	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
      	at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4128)
      	at org.eclipse.swt.widgets.Widget.sendEvent_aroundBody2(Widget.java:1457)
      	at org.eclipse.swt.widgets.Widget$AjcClosure3.run(Widget.java:1)
      	at com.xored.tesla.recording.aspects.RecordingAspect.ajc$around$com_xored_tesla_recording_aspects_RecordingAspect$4$2f127892proceed(RecordingAspect.aj:1)
      	at com.xored.tesla.recording.aspects.RecordingAspect.ajc$around$com_xored_tesla_recording_aspects_RecordingAspect$4$2f127892(RecordingAspect.aj:134)
      	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1457)
      	at org.eclipse.swt.widgets.Widget.sendEvent_aroundBody4(Widget.java:1480)
      	at org.eclipse.swt.widgets.Widget$AjcClosure5.run(Widget.java:1)
      	at com.xored.tesla.recording.aspects.RecordingAspect.ajc$around$com_xored_tesla_recording_aspects_RecordingAspect$1$bd9fb3e7proceed(RecordingAspect.aj:1)
      	at com.xored.tesla.recording.aspects.RecordingAspect.ajc$around$com_xored_tesla_recording_aspects_RecordingAspect$1$bd9fb3e7(RecordingAspect.aj:67)
      	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1469)
      	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1465)
      	at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:1270)
      	at com.xored.tesla.internal.ui.player.EventBuilder.send(EventBuilder.java:32)
      	at com.xored.tesla.internal.ui.processors.DragSupport$1.run(DragSupport.java:181)
      	at com.xored.tesla.internal.ui.player.SWTUIPlayer$8.run(SWTUIPlayer.java:2682)
      	... 33 more
          
  • 1.2.16
    • Replay script from 1.2.17 throws same error
    • Rerecording replays fine

Activity

komaz added a comment - 11/Feb/13 10:21 AM

Nastya, please check a latest binary build whether it has this error

anastasia.ahramenko added a comment - 11/Feb/13 2:55 PM

Verified on Q7-Q7D12-737 build, problem is not reproduced.


People

  • Assignee:
    anastasia.ahramenko
    Reporter:
    komaz
Vote (0)
Watch (0)

Dates

  • Created:
    11/Feb/13 10:16 AM
    Updated:
    11/Feb/13 2:55 PM
    Resolved:
    11/Feb/13 2:55 PM