Q7

At the replaying test the "get-text-viewer" command is failed

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.3.0
  • Fix Version/s: 1.3.1
  • Component/s: Runtime
  • Labels:
    None
  • Test Mode:
    Q7
  • Q7 test:
    UndoRedoDescriptionInDefaultContext

Description

Steps to reproduce:
1. The following steps is recorded:

Issue Links

Activity

Vasili Gulevich added a comment - 17/Apr/13 2:28 PM

The problem is partially caused by strange close command behaviour described in QS-2608.

Vasili Gulevich added a comment - 17/Apr/13 3:13 PM

After invalid close command fix, test fails later:

Execution failed on line 34 at column 24 (UndoRedoDescriptionInDefaultContext.test:34)
Caused by:
	The control "Undo" is disabled.

Failing code:

get-view "Q7 Explorer" | get-tree | select "TestProject/Project Settings" | double-click
get-editor "TestProject - Project Settings" | get-section Description | get-button "Clear Description" | click
get-menu "Edit/Undo" | click
Execution failed on line 34 at column 24 (UndoRedoDescriptionInDefaultContext.test:34)
Caused by:
	The control "Undo" is disabled.
Failing code:
get-view "Q7 Explorer" | get-tree | select "TestProject/Project Settings" | double-click
get-editor "TestProject - Project Settings" | get-section Description | get-button "Clear Description" | click
get-menu "Edit/Undo" | click
Vasili Gulevich added a comment - 17/Apr/13 5:51 PM

Fixed focus problem after clicking Clear description tool.
Undo history reset after document opening is emptied to forget
events that happen during initialization.
Two corresponding tests added:
UndoAfterClear
NoUndoInReopenedDocument


People

Vote (0)
Watch (0)

Dates

  • Created:
    18/Mar/13 5:23 PM
    Updated:
    17/Apr/13 5:51 PM
    Resolved:
    17/Apr/13 5:51 PM