Q7

Delete dialog hangs if automatic build is turned off

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: None
  • Fix Version/s: 1.2.19
  • Component/s: Runtime
  • Labels:
    None
  • Test Mode:
    Q7
  • Q7 test:
    DeleteWithoutAutoBuild

Description

This problem only happens if reproduced with Q7 test.
1. Use context with test suite.
2. Disable auto build
3. Try to delete one of test cases from Q7 Explorer view.
4. Q7 script hangs after delete dialog appearance.

Attached test illustrates a problem.

Activity

Vasili Gulevich added a comment - 17/Apr/13 11:22 AM

Fixed a bug of AutoBuild handling in UIJobCollector. The problem was caused by an extra call to Display.syncExec() that caused tesla event queue to always be nonempty.


People

Vote (0)
Watch (0)

Dates

  • Created:
    16/Apr/13 12:42 PM
    Updated:
    17/Apr/13 11:22 AM
    Resolved:
    17/Apr/13 11:22 AM