Q7

Wrong report at replaying the switch workspace test on agent

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.19
  • Fix Version/s: 1.2.22, 1.3.5
  • Component/s: Reporting
  • Labels:
    None
  • Test Mode:
    Manual
  • Q7 test:
    QS_2530_SwitchingWorkspaceTest

Description

"QS_2530_SwitchingWorkspaceTest" test passes according to Q7 Runner stdout, but report contains an error:

  testcase: Unknown reason (QS_2530_SwitchingWorkspaceTest)

Activity

komaz added a comment - 14/Jun/13 10:36 AM - edited

Steps to reproduce:

  1. Create a test case which restarts AUT with switching workspace:
    get-menu "File/Switch Workspace/Other..." | click
    get-window "Workspace Launcher" | get-button OK | click
    wait-until-eclipse-is-ready
    get-view "Package Explorer" | get-tree | select helloWorld
    
  2. Replay it, Execution view shows that test case has passed
  3. Try to save JUnit report from it
  1. Create a test case which restarts AUT with switching workspace:
    get-menu "File/Switch Workspace/Other..." | click
    get-window "Workspace Launcher" | get-button OK | click
    wait-until-eclipse-is-ready
    get-view "Package Explorer" | get-tree | select helloWorld
    
  2. Replay it, Execution view shows that test case has passed
  3. Try to save JUnit report from it
komaz added a comment - 14/Jun/13 10:37 AM

Oops, looks like something with restart is completely broken – Q7 hangs on 'wait-until-eclipse-is-ready' forever though AUT restarts OK

komaz added a comment - 09/Jul/13 8:57 PM

Problem from previous comment is already fixed.

The reason of this issue is that we handle restarts like this now:

  • Before shutdown, Q7 persists current report into workspace's metadata
  • During startup, Q7 loads persisted report from metadata and clears it

So, when we switch workspace, previously saved report is left in an old workspace and therefore there's no report

  • Before shutdown, Q7 persists current report into workspace's metadata
  • During startup, Q7 loads persisted report from metadata and clears it
So, when we switch workspace, previously saved report is left in an old workspace and therefore there's no report
komaz added a comment - 09/Jul/13 8:58 PM

Solution: persist report between restarts on Q7 side and explicitly send it back after AUT restart is complete

komaz added a comment - 10/Jul/13 1:24 PM

Fixed, now report is being saved in configuration area instead of workspace metadata


People

  • Assignee:
    komaz
    Reporter:
    anastasia.ahramenko
Vote (0)
Watch (0)

Dates

  • Created:
    08/May/13 12:27 PM
    Updated:
    10/Jul/13 1:24 PM
    Resolved:
    10/Jul/13 1:24 PM