Q7

Suite editor should update the name of the test case if it changed

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.19
  • Fix Version/s: 1.2.21
  • Component/s: UI
  • Labels:
    None
  • Test Mode:
    Manual

Activity

komaz added a comment - 11/Jun/13 11:43 AM

Steps to reproduce:

  1. Create test case tc1
  2. Create test suite ts1
  3. Add tc1 to ts1
  4. Change test case name to tc2 in test case editor
  5. Go back to test suite editor – it still displays a tc1 until editor is reopened

Since same scenario with renaming a context correctly updates test case editor, this should be doable

  1. Create test case tc1
  2. Create test suite ts1
  3. Add tc1 to ts1
  4. Change test case name to tc2 in test case editor
  5. Go back to test suite editor – it still displays a tc1 until editor is reopened
Since same scenario with renaming a context correctly updates test case editor, this should be doable
alexander.sheboltaev added a comment - 11/Jun/13 12:47 PM

consider renaming refactoring (F2) & changing name in editor and saving

alexander.sheboltaev added a comment - 11/Jun/13 5:36 PM

fixed, but should be optimized

alexander.sheboltaev added a comment - 14/Jun/13 10:26 AM

similar case for children test suites

alexander.sheboltaev added a comment - 14/Jun/13 10:35 AM

the same editor case (tab right click -> New Editor) – need to synchronize

Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open In Progress In Progress
17d 16h 37m 1 alexander.sheboltaev 11/Jun/13 11:51 AM
Resolved Resolved Reopened Reopened
1d 18h 54m 1 alexander.sheboltaev 13/Jun/13 12:30 PM
Reopened Reopened In Progress In Progress
20h 28m 1 alexander.sheboltaev 14/Jun/13 8:59 AM
In Progress In Progress Resolved Resolved
7h 57m 2 alexander.sheboltaev 14/Jun/13 11:12 AM

People

  • Assignee:
    alexander.sheboltaev
    Reporter:
    sergey
Vote (0)
Watch (0)

Dates

  • Created:
    24/May/13 7:14 PM
    Updated:
    14/Jun/13 11:12 AM
    Resolved:
    14/Jun/13 11:12 AM