Q7

Q7 records row header click as a general item selection.

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.2.21, 1.3.4
  • Fix Version/s: 1.2.24, 1.3.8
  • Component/s: Recording
  • Labels:
  • Test Mode:
    Manual

Description

Steps to reproduce:

1) new_table_1A;
2) select any row by clicking on a row header;
3) Press DEL key - the whole row is deleted.

Try to replay - Q7 clicks on an item instead of the row header and row is not deleted - just its content.

Issue Links

Activity

alexander.sheboltaev added a comment - 30/Aug/13 7:15 PM - edited

The issue is actual for grids with Cell Selection feature turned on.

The following syntax is proposed for selecting (meaning SetSelection) cells:

select [get-item "Item Label" | get-item-cell -column "Column Title"]
select [get-item "Item Label" | get-row-header]

Yet there is one more thing to think about: when we click on row header, whole item is selected (all its cells are); so maybe it's better to use select "Item Label" (default syntax for grids without cell selection ability) for that case, and not get-row-header?.. For cells selection the syntax proposed above still to be used.

select [get-item "Item Label" | get-item-cell -column "Column Title"]
select [get-item "Item Label" | get-row-header]
Yet there is one more thing to think about: when we click on row header, whole item is selected (all its cells are); so maybe it's better to use select "Item Label" (default syntax for grids without cell selection ability) for that case, and not get-row-header?.. For cells selection the syntax proposed above still to be used.
alexander.sheboltaev added a comment - 06/Sep/13 12:19 PM

Cells & row headers selection has been implemented, but items are not removed properly. Now I reverse engineering MetusGrid to find out why.

alexander.sheboltaev added a comment - 06/Sep/13 3:48 PM

Fixed items selection and deletion by row-header, but we have another Metus trait: you can select an item not only by its row header, but by its icon too!!

Also, menu-clicks recording now generates code like:

get-editor aaa | get-nebula-grid | select [get-item cc | get-item-cell -column Name] | get-item cc | get-item-cell -column Name | get-menu "Create Chart From Table..." | click
get-editor aaa | get-nebula-grid | select [get-item cc | get-item-cell -column Name] | get-item cc | get-item-cell -column Name | get-menu "Create Chart From Table..." | click
alexander.sheboltaev added a comment - 09/Sep/13 6:01 PM

Splitting get-menu commands from select is done.

Only error handling is remaining.


People

Vote (0)
Watch (1)

Dates

  • Created:
    24/Jul/13 1:48 PM
    Updated:
    11/Sep/13 5:04 PM
    Resolved:
    10/Sep/13 6:31 PM