Q7

JUnit XML report does not handle test cases with supercontexts correctly

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.3.5
  • Fix Version/s: 1.3.6
  • Component/s: Runner
  • Labels:
    None
  • Test Mode:
    Manual

Description

  1. Use attached project
  2. Run test case from a project. Make sure that execution view displays two test cases:
    • Asserts (fail)
    • Asserts (pass)
  3. Save JUnit XML report from Execution view
    JUnit XML report does not include supercontext names in test case names, so we see a confusing picture that there are two test cases with the same name, but one succeeds and anothef fails:
    <?xml version="1.0" ?><testsuite name="Asserts_2013_07_29" time="2.18" failures="1" tests="2" skipped="0" errors="0"><testcase name="Asserts" time="1.500"><failure type="testcase" message="Assertion failed: expected 'true' but was 'false' (Asserts)
    Caused by:Assertion failed: expected 'true' but was 'false' [assert-true]
    
    "></failure></testcase><testcase name="Asserts" time="0.518"></testcase></testsuite>
    

On contrary, HTML report does include context names.

Once fixed, we need to check whether Hudson can handle test names with curly braces correctly. If not, then we need to use some other 'encoding' (like underscores).

Activity

Stanislav Belyakov added a comment - 30/Jul/13 7:39 PM

Fixed


People

Vote (0)
Watch (0)

Dates

  • Created:
    29/Jul/13 8:00 PM
    Updated:
    30/Jul/13 7:39 PM
    Resolved:
    30/Jul/13 7:39 PM