Q7

Invalid thread access using ProgressMonitorDialog

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Cannot Reproduce
  • Affects Version/s: 1.3.7
  • Fix Version/s: 1.3.10
  • Component/s: Runtime
  • Labels:
  • Test Mode:
    Manual

Description

http://support.xored.com/helpdesk/tickets/516

I am having troubles with an AUT that is using a ProgressMonitorDialog. The code goes like this:

new ProgressMonitorDialog(shell).run(true, false, runner);

If the fork parameter is set to true then I get an Exception (invalid thread access) when the tests are running in my CI server.
Setting the fork parameter to false (forcing the stuff to be executed in the UI thread) resolves the problem.
Please note that I don't have this problem when I use my AUT, I am receiving the error only during testing.

Activity

Andrey Sobolev added a comment - 10/Oct/13 10:27 PM

Added Quality test with simple code snippet. Working as expected, no NPE's.

It seems we can't do anything without knowing exact exception.

Andrey Sobolev added a comment - 25/Oct/13 2:15 PM

Marked as cannot reproduce, created test snippet in Q7 quality suite.


People

Vote (0)
Watch (0)

Dates

  • Created:
    08/Oct/13 2:09 PM
    Updated:
    25/Oct/13 2:15 PM
    Resolved:
    25/Oct/13 2:15 PM