Q7

Key Type Enter playback Inconsistent with v1.3.9

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Cannot Reproduce
  • Affects Version/s: 1.3.9
  • Fix Version/s: 1.3.12
  • Component/s: Runtime
  • Labels:
  • Test Mode:
    Manual

Description

Activity

Ulyana Skorokhodova added a comment - 29/Oct/13 9:50 AM

Can't reproduce it on Q7 3.1.9, key-type Enter works successfully for me.
Just captured this test which is played back successfully:

with [get-view Properties | get-tree] {

    select Name | activate-cell-edit -column 1

    apply-cell-edit

    select Name | activate-cell-edit -column 1

    select Name | get-editbox | set-text uuuuu

    get-editbox | key-type Enter

    apply-cell-edit

    select "Ns Prefix" | activate-cell-edit -column 1

    select "Ns Prefix" | get-editbox | set-text pppp

    get-editbox | key-type Enter

    apply-cell-edit

}
with [get-view Properties | get-tree] {

    select Name | activate-cell-edit -column 1

    apply-cell-edit

    select Name | activate-cell-edit -column 1

    select Name | get-editbox | set-text uuuuu

    get-editbox | key-type Enter

    apply-cell-edit

    select "Ns Prefix" | activate-cell-edit -column 1

    select "Ns Prefix" | get-editbox | set-text pppp

    get-editbox | key-type Enter

    apply-cell-edit

}
Ulyana Skorokhodova made changes - 28/Mar/14 1:44 PM
Assignee Ivan Inozemtsev [ komaz ] Vasili Gulevich [ vasili.gulevich ]
Vasili Gulevich added a comment - 06/May/14 7:36 PM - edited

What is expected behaviour? How do I reproduce this for 1.3.12?

Vasili Gulevich made changes - 06/May/14 7:36 PM
Assignee Vasili Gulevich [ vasili.gulevich ] Ulyana Skorokhodova [ ulik ]
Ulyana Skorokhodova added a comment - 07/May/14 10:30 AM

Please see the comments in the customer's ticket(http://support.xored.com/helpdesk/tickets/556).

Ulyana Skorokhodova made changes - 07/May/14 10:30 AM
Assignee Ulyana Skorokhodova [ ulik ] Vasili Gulevich [ vasili.gulevich ]
Vasili Gulevich added a comment - 15/May/14 2:50 PM

Can't reproduce on actual 1.3.12. A pair of mockups has been updated to delayed model update. We can suppose client AUT uses Threads instead of jobs preventing Q7 from work detection.

Vasili Gulevich made changes - 21/May/14 6:04 PM
Resolution Cannot Reproduce [ 5 ]
Status Open [ 1 ] Resolved [ 5 ]
Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open Resolved Resolved
204d 7h 15m 1 Vasili Gulevich 21/May/14 6:04 PM

People

Vote (0)
Watch (0)

Dates

  • Created:
    29/Oct/13 9:49 AM
    Updated:
    21/May/14 6:04 PM
    Resolved:
    21/May/14 6:04 PM