Q7

ExpandBar is not supported

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.3.10
  • Fix Version/s: 1.3.11
  • Component/s: Runtime
  • Labels:
  • Test Mode:
    Q7
  • Q7 test:
    q7.quality.mockups\tests\coverage\swt\expandBar\...

Description

  1. Create simple org.eclipse.swt.widgets.ExpandBar (see attachment)
  2. Start recording
  3. Change expand state (expand and collapse bar's items)
    Nothing will be recorded

Issue Links

Activity

Ulyana Skorokhodova added a comment - 06/Feb/14 12:28 PM - edited

Reopening due to some bugs are found.

Use ExpandBar Mockup to reproduce.

  1. If I have same-named items, actions performed on items with index cannpot be replayed:
      get-expand-bar | get-item item -index 1 | expand
      
  2. Item's image cannot be asserted (can't find in item properties).
  1. If I have same-named items, actions performed on items with index cannpot be replayed:
      get-expand-bar | get-item item -index 1 | expand
      
  2. Item's image cannot be asserted (can't find in item properties).
Ulyana Skorokhodova made changes - 06/Feb/14 12:28 PM
Status Resolved [ 5 ] Reopened [ 4 ]
Resolution Fixed [ 1 ]
komaz added a comment - 07/Feb/14 12:28 PM

fixed

Ulyana Skorokhodova made changes - 07/Feb/14 1:39 PM
Test Mode Manual Q7
Q7 test q7.quality.mockups\tests\coverage\swt\expandBar\...
Vasili Gulevich made changes - 28/Mar/14 10:44 AM
Link This issue duplicates QS-2580 [ QS-2580 ]
Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open Resolved Resolved
77d 7h 39m 1 komaz 05/Feb/14 6:46 PM
Resolved Resolved Reopened Reopened
17h 41m 1 Ulyana Skorokhodova 06/Feb/14 12:28 PM
Reopened Reopened Resolved Resolved
1d 1 komaz 07/Feb/14 12:28 PM

People

  • Assignee:
    komaz
    Reporter:
    torsion
Vote (0)
Watch (0)

Dates

  • Created:
    20/Nov/13 11:07 AM
    Updated:
    28/Mar/14 10:44 AM
    Resolved:
    07/Feb/14 12:28 PM