Q7

Q7 doesn't record clicks into a field if it is empty.

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Minor Minor
  • Resolution: Fixed
  • Affects Version/s: 1.3.9
  • Fix Version/s: 1.3.11
  • Component/s: Recording
  • Labels:
    None
  • Test Mode:
    Q7
  • Q7 test:
    CopyPasteWithMenuIntoEmptyField

Description

Steps to reproduce:

Use Q7 as AUT.
Open a test case editor with empty Tags field. Start recording.

  1. Select text in Name field;
  2. Choose Edit/Copy;
  3. Left click into Tags field;
  4. Right click in Tags field
  5. Choose Edit/Paste.

Bug: no script is recorded for left click into a Tags field.

Activity

Vasili Gulevich made changes - 23/Dec/13 1:42 PM
Assignee Ivan Inozemtsev [ komaz ] Vasili Gulevich [ vasili.gulevich ]
Vasili Gulevich made changes - 23/Dec/13 1:48 PM
Status Open [ 1 ] In Progress [ 3 ]
Vasili Gulevich added a comment - 23/Dec/13 2:06 PM - edited

I've managed to record following scriptlet without manual editing:

with [get-editor scenario] {
    with [get-editbox -after [get-label "Name:"]] {
        set-text-offset 4 0
        double-click
        set-text-selection -offset 0 -startLine 0 -endLine 0 -endOffset 8
        get-menu Copy | click
    }
    get-editbox -after [get-label "Tags:"] | get-menu Paste | click //Nothing recorded wrong here
}
get-editor scenario | get-editbox -after [get-label "Tags:"] | get-property text | equals scenario | verify-true

Oh, I get it now - nothing is recorded when you "left click" in a field.

with [get-editor scenario] {
    with [get-editbox -after [get-label "Name:"]] {
        set-text-offset 4 0
        double-click
        set-text-selection -offset 0 -startLine 0 -endLine 0 -endOffset 8
        get-menu Copy | click
    }
    get-editbox -after [get-label "Tags:"] | get-menu Paste | click //Nothing recorded wrong here
}
get-editor scenario | get-editbox -after [get-label "Tags:"] | get-property text | equals scenario | verify-true
Oh, I get it now - nothing is recorded when you "left click" in a field.
Vasili Gulevich added a comment - 23/Dec/13 2:08 PM

Ulyana, are my edits of description correct?

Vasili Gulevich made changes - 23/Dec/13 2:08 PM
Description Steps to reproduce:

Use Q7 as AUT.
Open a test case editor with empty Tags field. Start recording.

# Select text in Name field;
# Choose Edit/Copy;
# Click into Tags field;
# Choose Edit/Paste.

Bug: no script is recorded for click into a Tags field.
Steps to reproduce:

Use Q7 as AUT.
Open a test case editor with empty Tags field. Start recording.

# Select text in Name field;
# Choose Edit/Copy;
# Left click into Tags field;
# Right click in Tags field
# Choose Edit/Paste.

Bug: no script is recorded for left click into a Tags field.
Vasili Gulevich added a comment - 23/Dec/13 3:09 PM

com.xored.tesla.recording.core.swt.SWTEventRecorder.recordStyledTextOffset(StyledText) have been recording offset change only if text field was not empty. This check has been there since the very beginning: c1393f3bd84383e330b5927872b051d450cd3bcc.
Removed the check in c7cd8ab853b7f5faf46593246c8df8d000c70f1f.

Vasili Gulevich made changes - 23/Dec/13 3:20 PM
Status In Progress [ 3 ] Open [ 1 ]
Vasili Gulevich added a comment - 23/Dec/13 3:20 PM

Testing in experimental branch.

Vasili Gulevich made changes - 23/Dec/13 3:20 PM
Resolution Under testing [ 6 ]
Status Open [ 1 ] Resolved [ 5 ]
Vasili Gulevich made changes - 23/Dec/13 6:55 PM
Assignee Vasili Gulevich [ vasili.gulevich ] Ulyana Skorokhodova [ ulik ]
Ulyana Skorokhodova added a comment - 25/Dec/13 9:05 PM

Changing status to Under Testing

Ulyana Skorokhodova made changes - 25/Dec/13 9:05 PM
Status Resolved [ 5 ] Reopened [ 4 ]
Resolution Under testing [ 6 ]
Ulyana Skorokhodova made changes - 25/Dec/13 9:06 PM
Resolution Under testing [ 6 ]
Status Reopened [ 4 ] Resolved [ 5 ]
Ulyana Skorokhodova made changes - 26/Dec/13 3:45 AM
Q7 test CopyPasteWithMenuIntoEmptyField
Test Mode Manual Q7
Status Resolved [ 5 ] Closed [ 6 ]
Ulyana Skorokhodova made changes - 26/Dec/13 3:45 AM
Status Closed [ 6 ] Reopened [ 4 ]
Resolution Under testing [ 6 ]
Ulyana Skorokhodova made changes - 26/Dec/13 3:45 AM
Resolution Fixed [ 1 ]
Status Reopened [ 4 ] Resolved [ 5 ]
Transition Time In Source Status Execution Times Last Executer Last Execution Date
Open Open In Progress In Progress
3d 1h 57m 1 Vasili Gulevich 23/Dec/13 1:48 PM
In Progress In Progress Open Open
1h 32m 1 Vasili Gulevich 23/Dec/13 3:20 PM
Open Open Resolved Resolved
17s 1 Vasili Gulevich 23/Dec/13 3:20 PM
Resolved Resolved Reopened Reopened
2d 5h 44m 1 Ulyana Skorokhodova 25/Dec/13 9:05 PM
Resolved Resolved Closed Closed
6h 38m 1 Ulyana Skorokhodova 26/Dec/13 3:45 AM
Closed Closed Reopened Reopened
8s 1 Ulyana Skorokhodova 26/Dec/13 3:45 AM
Reopened Reopened Resolved Resolved
1m 20s 2 Ulyana Skorokhodova 26/Dec/13 3:45 AM

People

Vote (0)
Watch (0)

Dates

  • Created:
    20/Dec/13 11:50 AM
    Updated:
    26/Dec/13 3:45 AM
    Resolved:
    26/Dec/13 3:45 AM