Q7

Q7 doesn't paste table item during the replay.

Details

  • Type: Bug Bug
  • Status: Closed Closed
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.3.11
  • Fix Version/s: 1.3.12
  • Component/s: Runtime
  • Labels:
    None
  • Test Mode:
    Manual

Description

Run the attached Q7 test case to reproduce(use Vozone as AUT).
Test Case fails (at line 7) because bundle isn't pasted.

Activity

Ulyana Skorokhodova added a comment - 04/Apr/14 10:13 AM

Probably the throwing Vozone exceptions may affect this:

org.eclipse.core.runtime.AssertionFailedException: assertion failed: This operation must be run within the observable's realm
	at org.eclipse.core.runtime.Assert.isTrue(Assert.java:110)
	at org.eclipse.core.databinding.observable.AbstractObservable.checkRealm(AbstractObservable.java:98)
	at org.eclipse.core.databinding.observable.value.AbstractObservableValue.setValue(AbstractObservableValue.java:54)
	at org.eclipse.core.databinding.ListBinding$5.run(ListBinding.java:218)
	at org.eclipse.core.databinding.observable.Realm$1.run(Realm.java:148)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.core.databinding.observable.Realm.safeRun(Realm.java:152)
	at org.vozone.commons.core.databinding.WriteDomainRealm.access$1(WriteDomainRealm.java:1)
	at org.vozone.commons.core.databinding.WriteDomainRealm$2.doExecute(WriteDomainRealm.java:42)
	at org.eclipse.emf.workspace.AbstractEMFOperation.execute(AbstractEMFOperation.java:150)
	at org.vozone.commons.core.databinding.WriteDomainRealm.runInTransaction(WriteDomainRealm.java:47)
	at org.vozone.commons.core.databinding.WriteDomainRealm.access$0(WriteDomainRealm.java:38)
	at org.vozone.commons.core.databinding.WriteDomainRealm$1.run(WriteDomainRealm.java:33)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.vozone.commons.core.databinding.WriteDomainRealm.syncExec(WriteDomainRealm.java:30)
	at org.eclipse.core.databinding.observable.Realm$3.run(Realm.java:255)
org.eclipse.core.runtime.AssertionFailedException: assertion failed: This operation must be run within the observable's realm
	at org.eclipse.core.runtime.Assert.isTrue(Assert.java:110)
	at org.eclipse.core.databinding.observable.AbstractObservable.checkRealm(AbstractObservable.java:98)
	at org.eclipse.core.databinding.observable.value.AbstractObservableValue.setValue(AbstractObservableValue.java:54)
	at org.eclipse.core.databinding.ListBinding$5.run(ListBinding.java:218)
	at org.eclipse.core.databinding.observable.Realm$1.run(Realm.java:148)
	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
	at org.eclipse.core.databinding.observable.Realm.safeRun(Realm.java:152)
	at org.vozone.commons.core.databinding.WriteDomainRealm.access$1(WriteDomainRealm.java:1)
	at org.vozone.commons.core.databinding.WriteDomainRealm$2.doExecute(WriteDomainRealm.java:42)
	at org.eclipse.emf.workspace.AbstractEMFOperation.execute(AbstractEMFOperation.java:150)
	at org.vozone.commons.core.databinding.WriteDomainRealm.runInTransaction(WriteDomainRealm.java:47)
	at org.vozone.commons.core.databinding.WriteDomainRealm.access$0(WriteDomainRealm.java:38)
	at org.vozone.commons.core.databinding.WriteDomainRealm$1.run(WriteDomainRealm.java:33)
	at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
	at org.vozone.commons.core.databinding.WriteDomainRealm.syncExec(WriteDomainRealm.java:30)
	at org.eclipse.core.databinding.observable.Realm$3.run(Realm.java:255)
Ulyana Skorokhodova added a comment - 04/Apr/14 10:26 AM

Probably this one is a Default one. You can find the tests in a Vozone Repo (ConductorBundle_CopyPaste_Button_SameCableSection).

Ulyana Skorokhodova added a comment - 21/Apr/14 12:41 PM

Seems to be fixed.


People

Vote (0)
Watch (0)

Dates

  • Created:
    04/Apr/14 10:09 AM
    Updated:
    21/Apr/14 12:41 PM
    Resolved:
    21/Apr/14 12:41 PM