Q7

Significant delays when using Advanced properties in assertion mode

Details

  • Type: Bug Bug
  • Status: Resolved Resolved
  • Priority: Major Major
  • Resolution: Fixed
  • Affects Version/s: 1.3.12
  • Fix Version/s: 1.3.13
  • Component/s: Recording
  • Labels:
    None
  • Test Mode:
    Manual

Description

Ticket 893

Performance issues when selecting properties for assertion in some scenarios. For example while recording the following assertion code:

get-editor JavaFxTest | get-canvas | get-property "getScene().getRoot().getChildren().EditorPane[1].getChildren().HBox[3].getLayoutX()" | equals "200.0" | verify-true

When selecting the checkbox next to getLayoutX(), a delay of about 5 seconds occurs each time I click the checkbox. Moreover, the Add-Button remains disabled (gray) for further 5 seconds. In larger trees this delay increases extensively.

Activity

Vasili Gulevich added a comment - 23/Jun/14 7:50 PM

Period of no response is reduced significantly.

Ulyana Skorokhodova added a comment - 20/Jun/14 11:35 AM

Issue is still reproducible on RCPTT-75.

Steps to reproduce:

1) Create New RCPTT Project with a test case;
2) Start recording, switch to assertion mode and try to assert

get-view "Test Explorer" | get-tree | get-item MyProject 
    | get-property "getParent().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getEnabled()" 
    | equals true | verify-true

While going deep into a properties hierarchy, the actions (such as check/uncheck advanced properties) in assertion window are executed with a delay.

get-view "Test Explorer" | get-tree | get-item MyProject 
    | get-property "getParent().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getShell().getEnabled()" 
    | equals true | verify-true
While going deep into a properties hierarchy, the actions (such as check/uncheck advanced properties) in assertion window are executed with a delay.
Vasili Gulevich added a comment - 18/Jun/14 12:40 PM
Ulyana Skorokhodova added a comment - 05/May/14 4:35 PM

Reproduced on Win32 OS.
The reason is in Q7, not in JavaFX (could reproduce a delay by asserting a tree view).

komaz added a comment - 30/Apr/14 2:27 PM

Ulyana, have you ever observed such performance issues with advanced properties? Could you try reproducing it on Windows? (on any control, not necessary FXCanvas)

komaz added a comment - 30/Apr/14 2:26 PM

So far could not reproduce on Mac OS X – even when Assertion tree has about 1500 elements, check/uncheck and Add button enablement state show no delays


People

Vote (0)
Watch (0)

Dates

  • Created:
    29/Apr/14 9:43 PM
    Updated:
    23/Jun/14 7:50 PM
    Resolved:
    23/Jun/14 7:50 PM